aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/octave/octave_3.0.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/octave/octave_3.0.0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/octave/octave_3.0.0.bb')
-rw-r--r--recipes/octave/octave_3.0.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/octave/octave_3.0.0.bb b/recipes/octave/octave_3.0.0.bb
new file mode 100644
index 0000000000..3b56c8657d
--- /dev/null
+++ b/recipes/octave/octave_3.0.0.bb
@@ -0,0 +1,27 @@
+require octave.inc
+
+SRC_URI = "ftp://ftp.octave.org/pub/octave/${PN}-${PV}.tar.gz \
+ file://configure.patch;patch=1"
+
+PR = "r1"
+
+PACKAGES =+ "libcruft liboctave liboctinterp octave-oct \
+ libcruft-dev liboctave-dev liboctinterp-dev \
+ libcruft-dbg liboctave-dbg liboctinterp-dbg"
+
+FILES_libcruft = "${libdir}/${PN}-${PV}/libcruft.so.*"
+FILES_libcruft-dev = "${libdir}/${PN}-${PV}/libcruft*"
+FILES_libcruft-dbg += "${libdir}/${PN}-${PV}/.debug/libcruft*"
+
+FILES_liboctave = "${libdir}/${PN}-${PV}/liboctave.so.*"
+FILES_liboctave-dev = "${libdir}/${PN}-${PV}/liboctave*"
+FILES_liboctave-dbg += "${libdir}/${PN}-${PV}/.debug/liboctave*"
+
+FILES_liboctinterp = "${libdir}/${PN}-${PV}/liboctinterp.so.*"
+FILES_liboctinterp-dev = "${libdir}/${PN}-${PV}/liboctinterp*"
+FILES_liboctinterp-dbg += "${libdir}/${PN}-${PV}/.debug/liboctinterp*"
+
+# octave-oct provides subroutines in .oct file format
+FILES_${PN}-oct = "${libexecdir}/${PN}/${PV}/oct/${TARGET_SYS}/*.oct"
+
+FILES_${PN}-dbg += "${libexecdir}/${PN}/${PV}/oct/${TARGET_SYS}/.debug"