aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/omniorb
diff options
context:
space:
mode:
authorFahad Usman <fahad_usman@mentor.com>2010-09-09 06:30:47 +0000
committerTom Rini <tom_rini@mentor.com>2010-09-30 14:10:04 -0700
commitfe6da768cb04751022663620fba830b28374923d (patch)
tree97b9eed1d918b9dd1cc920d485fef36de1366cdb /recipes/omniorb
parent44af05077f455f5b76cf76eb41dcc62a51de7582 (diff)
downloadopenembedded-fe6da768cb04751022663620fba830b28374923d.tar.gz
omniorb_4.1.4: merged native and non-native recipes
* removed the omniorb-native_4.1.4.bb file * added DEPENDS_pn-omniorb = "omniorb-native" and DEPENDS_pn-omniorb-native += "python-native" to handle different dependencies for native and target recipes, thanks to Vitus Jensen for guidance * added NATIVE_INSTALL_WORKS = "1" * added BBCLASSEXTEND = "native" * added do_install_virtclass-native and converted do_stage from native recipe in the combined recipe * bumped PR Signed-off-by: Fahad Usman <fahad_usman@mentor.com> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/omniorb')
-rw-r--r--recipes/omniorb/omniorb-native_4.1.4.bb23
-rw-r--r--recipes/omniorb/omniorb_4.1.4.bb31
2 files changed, 25 insertions, 29 deletions
diff --git a/recipes/omniorb/omniorb-native_4.1.4.bb b/recipes/omniorb/omniorb-native_4.1.4.bb
deleted file mode 100644
index c5c550d0ec..0000000000
--- a/recipes/omniorb/omniorb-native_4.1.4.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-SECTION = "devel"
-DEPENDS += "python-native"
-PR = "r0"
-
-SRC_URI = "http://downloads.sourceforge.net/omniorb/omniORB-4.1.4.tar.gz;name=omniORB414targz \
- file://omniorb_4.1.4.patch \
-"
-
-SRC_URI[omniORB414targz.md5sum] = "1f6070ff9b6339876976d61981eeaa6a"
-SRC_URI[omniORB414targz.sha256sum] = "84fb9790c25d6e46248c9773747e393b429573190da2150850d4a49debda4e8e"
-
-S = "${WORKDIR}/omniORB-${PV}"
-
-inherit native autotools
-
-do_compile () {
- oe_runmake
-}
-# Ugly hack so libtool does not find native libs when building cross packages
-# We really only build this package for omniidl anyway
-do_stage_append() {
- rm -f ${STAGING_LIBDIR_NATIVE}/libomni*
-}
diff --git a/recipes/omniorb/omniorb_4.1.4.bb b/recipes/omniorb/omniorb_4.1.4.bb
index a4c032c5d3..ff68b72de5 100644
--- a/recipes/omniorb/omniorb_4.1.4.bb
+++ b/recipes/omniorb/omniorb_4.1.4.bb
@@ -2,8 +2,9 @@ DESCRIPTION = "OmniORB High Performance ORB"
SECTION = "devel"
PRIORITY = "optional"
LICENSE = "LGPL"
-DEPENDS = "omniorb-native"
-PR = "r0"
+DEPENDS_pn-omniorb = "omniorb-native"
+DEPENDS_pn-omniorb-native += "python-native"
+PR = "r1"
SRC_URI = "http://downloads.sourceforge.net/omniorb/omniORB-4.1.4.tar.gz;name=omniORB414targz \
file://omniorb_4.1.4.patch \
@@ -12,6 +13,10 @@ file://omniORB-cross.patch \
file://omniORB_embedded_appl.patch \
file://rm_LongDouble.patch \
"
+SRC_URI_virtclass-native = "http://downloads.sourceforge.net/omniorb/omniORB-4.1.4.tar.gz;name=omniORB414targz \
+ file://omniorb_4.1.4.patch \
+"
+
SRC_URI[omniORB414targz.md5sum] = "1f6070ff9b6339876976d61981eeaa6a"
SRC_URI[omniORB414targz.sha256sum] = "84fb9790c25d6e46248c9773747e393b429573190da2150850d4a49debda4e8e"
@@ -29,9 +34,15 @@ do_compile () {
oe_runmake
}
+
+do_compile_virtclass-native() {
+ oe_runmake
+}
+
do_install () {
+ # Set a variable that the Makefiles obey for install.
export EmbeddedSystem=1
- make DESTDIR=${D} install
+ autotools_do_install
install -d ${D}${sysconfdir}
install -m 0644 ${WORKDIR}/omniORB.cfg ${D}${sysconfdir}
install -d ${D}${localstatedir}/omninames
@@ -39,7 +50,15 @@ do_install () {
#only executable libraries are stripped by the stripper
chmod +x ${WORKDIR}/image/usr/lib/lib*
}
-do_stage () {
- export EmbeddedSystem=1
- autotools_stage_all
+
+do_install_virtclass-native() {
+ autotools_do_install
+
+ # Ugly hack so libtool does not find native libs when building cross
+ # packages We really only build this package for omniidl anyway
+ rm -f ${D}${libdir}/libomni*
}
+
+BBCLASSEXTEND = "native"
+
+NATIVE_INSTALL_WORKS = "1"