aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/oneko/oneko_1.2.sakura.5.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/oneko/oneko_1.2.sakura.5.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/oneko/oneko_1.2.sakura.5.bb')
-rw-r--r--recipes/oneko/oneko_1.2.sakura.5.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/oneko/oneko_1.2.sakura.5.bb b/recipes/oneko/oneko_1.2.sakura.5.bb
new file mode 100644
index 0000000000..efec192cc6
--- /dev/null
+++ b/recipes/oneko/oneko_1.2.sakura.5.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Small cat chasing mouse cursor"
+AUTHOR = "Tatsuya Kato"
+HOMEPAGE = "http://www.daidouji.com/oneko/"
+SECTION = "x11/applications"
+PRIORITY = "optional"
+LICENSE = "PD"
+DEPENDS = "virtual/libx11 libxext"
+
+SRC_URI = "http://www.daidouji.com/oneko/distfiles/oneko-${PV}.tar.gz \
+ file://oneko.desktop \
+ file://kill-oneko.desktop \
+ file://oneko.png \
+ file://kill-oneko.png \
+ file://remove-bsd-daemon-logo.patch;patch=1"
+
+inherit pkgconfig
+
+do_compile() {
+ ${CC} oneko.c -o oneko -lm `pkg-config --cflags --libs x11 xext` \
+ -DSHAPE
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -d ${D}/${datadir}/applications
+ install -d ${D}/${datadir}/pixmaps
+ install -d ${D}/${mandir}/man6
+ install -m 0755 ${S}/oneko ${D}/${bindir}
+ install -m 0644 ${WORKDIR}/*oneko.png ${D}/${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/*oneko.desktop ${D}/${datadir}/applications
+ install -m 0644 ${S}/oneko.man ${D}/${mandir}/man6/oneko.6
+}
+
+
+