aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/open-iscsi
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-10-26 16:42:07 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-10-26 16:42:07 +0100
commit26834267421183e1abef0dc880ac0a0ad5a9c6a1 (patch)
treeb2cba45cd5732640298a43009234c6bf34382e48 /recipes/open-iscsi
parentd7e9f09e299b037f6a749a77e9e3385dfb1768f3 (diff)
downloadopenembedded-26834267421183e1abef0dc880ac0a0ad5a9c6a1.tar.gz
open-iscsi: added recipe; still needs stress-testing
Diffstat (limited to 'recipes/open-iscsi')
-rw-r--r--recipes/open-iscsi/open-iscsi-kernel_2.0-871.bb19
-rw-r--r--recipes/open-iscsi/open-iscsi-user_2.0-871.bb16
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes/open-iscsi/open-iscsi-kernel_2.0-871.bb b/recipes/open-iscsi/open-iscsi-kernel_2.0-871.bb
new file mode 100644
index 0000000000..c58e142f4f
--- /dev/null
+++ b/recipes/open-iscsi/open-iscsi-kernel_2.0-871.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Open-iSCSI project is a high performance, transport independent, multi-platform implementation of RFC3720."
+HOMEPAGE = "http://www.open-iscsi.org/"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.open-iscsi.org/bits/open-iscsi-${PV}.tar.gz"
+S = "${WORKDIR}/open-iscsi-${PV}"
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+inherit module
+
+do_compile () {
+ oe_runmake 'KSRC=${STAGING_KERNEL_DIR}' LDFLAGS="" kernel
+}
+
+do_install() {
+ oe_runmake 'KSRC=${STAGING_KERNEL_DIR}' LDFLAGS="" DESTDIR="${D}" install_kernel
+}
+
diff --git a/recipes/open-iscsi/open-iscsi-user_2.0-871.bb b/recipes/open-iscsi/open-iscsi-user_2.0-871.bb
new file mode 100644
index 0000000000..92ecea1d3f
--- /dev/null
+++ b/recipes/open-iscsi/open-iscsi-user_2.0-871.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Open-iSCSI project is a high performance, transport independent, multi-platform implementation of RFC3720."
+HOMEPAGE = "http://www.open-iscsi.org/"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.open-iscsi.org/bits/open-iscsi-${PV}.tar.gz"
+S = "${WORKDIR}/open-iscsi-${PV}"
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_compile () {
+ oe_runmake user
+}
+
+do_install () {
+ oe_runmake DESTDIR="${D}" install_user
+}