aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openais
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-22 23:48:26 +0300
committerRoman I Khimov <khimov@altell.ru>2010-03-29 13:28:02 +0400
commit51151505671c6c1507aaf6e4d72dc856c621b5bd (patch)
tree8724c0fa72f0f1d11d02395f54fe91415644a868 /recipes/openais
parent5595df3516313bc8b3ffde448ce0c6abb086a1fc (diff)
downloadopenembedded-51151505671c6c1507aaf6e4d72dc856c621b5bd.tar.gz
openais: add new recipe
The OpenAIS Standards Based Cluster Framework is an OSI Certified implementation of the Service Availability Forum Application Interface Specification (AIS). The Application Interface Specification is a software API and policies which are used to develop applications that maintain service during faults. Restarting and failover of applications is also provided for those deploying applications which may not be modified. The OpenAIS software is built to operate as plugins to the Corosync Cluster Engine. Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/openais')
-rw-r--r--recipes/openais/files/fix-lcrso-linkage.patch21
-rw-r--r--recipes/openais/openais_1.1.2.bb14
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes/openais/files/fix-lcrso-linkage.patch b/recipes/openais/files/fix-lcrso-linkage.patch
new file mode 100644
index 0000000000..9acfc20266
--- /dev/null
+++ b/recipes/openais/files/fix-lcrso-linkage.patch
@@ -0,0 +1,21 @@
+Index: openais-1.1.2/services/Makefile.am
+===================================================================
+--- openais-1.1.2.orig/services/Makefile.am 2010-03-22 23:00:09.000000000 +0300
++++ openais-1.1.2/services/Makefile.am 2010-03-22 22:59:51.000000000 +0300
+@@ -78,13 +78,13 @@
+
+ else
+ service_amf.lcrso: $(AMF_OBJECTS)
+- $(CC) $(CFLAGS) -shared -Wl,-soname=$@ $^ -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname=$@ $^ -o $@
+
+ service_%.lcrso: %.o
+- $(CC) $(CFLAGS) -shared -Wl,-soname=$@ $^ -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname=$@ $^ -o $@
+
+ %.lcrso: %.o
+- $(CC) $(CFLAGS) -shared -Wl,-soname=$@ $^ -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname=$@ $^ -o $@
+ endif
+
+ %.o: %.c
diff --git a/recipes/openais/openais_1.1.2.bb b/recipes/openais/openais_1.1.2.bb
new file mode 100644
index 0000000000..c4c602d9c1
--- /dev/null
+++ b/recipes/openais/openais_1.1.2.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Implementation of the Service Availability Forum Application Interface Specification (AIS)"
+LICENSE = "BSD"
+DEPENDS = "cluster-glue corosync"
+
+SRC_URI = " \
+ ftp://ftp@openais.org/downloads/openais-${PV}/openais-${PV}.tar.gz;name=tar \
+ file://fix-lcrso-linkage.patch;patch=1 \
+ "
+SRC_URI[tar.md5sum] = "f94ccb867358ac54ab24bc54def27335"
+SRC_URI[tar.sha256sum] = "7ba87dc480a9dd224fe3a3732c966d6fdf6ec5f192bb184d586afa3703f808f2"
+
+inherit autotools_stage
+
+FILES_${PN}-dbg += "${libexecdir}/lcrso/.debug" \ No newline at end of file