aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openal
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/openal
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/openal')
-rw-r--r--recipes/openal/files/void-workaround.patch13
-rw-r--r--recipes/openal/openal_0.0.8.bb24
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes/openal/files/void-workaround.patch b/recipes/openal/files/void-workaround.patch
new file mode 100644
index 0000000000..c2698a95bb
--- /dev/null
+++ b/recipes/openal/files/void-workaround.patch
@@ -0,0 +1,13 @@
+Index: openal-0.0.8/common/include/AL/alc.h
+===================================================================
+--- openal-0.0.8.orig/common/include/AL/alc.h 2007-09-22 19:40:47.000000000 +0200
++++ openal-0.0.8/common/include/AL/alc.h 2007-09-22 19:41:04.000000000 +0200
+@@ -82,7 +82,7 @@
+ typedef double ALCdouble;
+
+ /** void type (for opaque pointers only) */
+-typedef void ALCvoid;
++#define ALCvoid void
+
+
+ /* Enumerant values begin at column 50. No tabs. */
diff --git a/recipes/openal/openal_0.0.8.bb b/recipes/openal/openal_0.0.8.bb
new file mode 100644
index 0000000000..280c5d75e8
--- /dev/null
+++ b/recipes/openal/openal_0.0.8.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "OpenAL is a cross-platform 3D audio API."
+DEPENDS = "alsa-lib virtual/libsdl libvorbis"
+
+SRC_URI = "http://www.openal.org/openal_webstf/downloads/${PN}-${PV}.tar.gz \
+ file://void-workaround.patch"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-alsa --enable-sdl --enable-vorbis --disable-mp3 \
+ --disable-smpeg --disable-arts"
+
+do_configure_append () {
+ sed -i "s/@requirements@/alsa vorbis/" admin/pkgconfig/openal.pc
+}
+
+do_stage () {
+ autotools_stage_all
+}
+
+PACKAGES =+ "libopenal"
+
+FILES_libopenal += "${libdir}/libopenal.so.*"
+FILES_openal-dev += "${bindir}/openal-config"
+FILES_openal = ""