aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openchrome
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/openchrome
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/openchrome')
-rw-r--r--recipes/openchrome/configure-dri.patch11
-rw-r--r--recipes/openchrome/configure.patch42
-rw-r--r--recipes/openchrome/openchrome.inc16
-rw-r--r--recipes/openchrome/openchrome_svn.bb5
-rw-r--r--recipes/openchrome/xf86-video-openchrome_0.2.902.bb4
5 files changed, 78 insertions, 0 deletions
diff --git a/recipes/openchrome/configure-dri.patch b/recipes/openchrome/configure-dri.patch
new file mode 100644
index 0000000000..605078ec2b
--- /dev/null
+++ b/recipes/openchrome/configure-dri.patch
@@ -0,0 +1,11 @@
+--- s/configure.ac~ 2008-07-27 10:50:51.000000000 +0100
++++ s/configure.ac 2008-07-27 10:57:25.000000000 +0100
+@@ -70,7 +70,7 @@
+ XORG_DRIVER_CHECK_EXT(DPMSExtension, xextproto)
+
+ # Checks for pkg-config packages
+-PKG_CHECK_MODULES(XORG, [xorg-server xproto xvmc fontsproto libdrm $REQUIRED_MODULES])
++PKG_CHECK_MODULES(XORG, [xorg-server xproto xvmc fontsproto libdrm xf86driproto $REQUIRED_MODULES])
+ sdkdir=$(pkg-config --variable=sdkdir xorg-server)
+
+ # Checks for libraries.
diff --git a/recipes/openchrome/configure.patch b/recipes/openchrome/configure.patch
new file mode 100644
index 0000000000..a2f236470d
--- /dev/null
+++ b/recipes/openchrome/configure.patch
@@ -0,0 +1,42 @@
+--- trunk/configure.ac 2007-01-16 16:58:44.000000000 +0000
++++ trunk/configure.ac 2007-01-16 18:09:26.000000000 +0000
+@@ -69,11 +69,11 @@
+ AC_HEADER_STDC
+
+ if test "$DRI" != no; then
+- AC_CHECK_FILE([${sdkdir}/dri.h],
++ AC_CHECK_BUILD_FILE([${sdkdir}/dri.h],
+ [have_dri_h="yes"], [have_dri_h="no"])
+- AC_CHECK_FILE([${sdkdir}/sarea.h],
++ AC_CHECK_BUILD_FILE([${sdkdir}/sarea.h],
+ [have_sarea_h="yes"], [have_sarea_h="no"])
+- AC_CHECK_FILE([${sdkdir}/dristruct.h],
++ AC_CHECK_BUILD_FILE([${sdkdir}/dristruct.h],
+ [have_dristruct_h="yes"], [have_dristruct_h="no"])
+ fi
+
+@@ -113,7 +113,7 @@
+
+ AM_CONDITIONAL(XVMC, test x$XVMC = xyes)
+
+-AC_CHECK_FILE([${sdkdir}/xf86Module.h],
++AC_CHECK_BUILD_FILE([${sdkdir}/xf86Module.h],
+ [have_xf86Module_h="yes"], [have_xf86Module_h="no"])
+
+ # Check the ABI_VIDEODRV_VERSION
+--- /dev/null 2003-09-15 14:40:47.000000000 +0100
++++ trunk/m4/check-build.m4 2007-01-16 18:07:37.000000000 +0000
+@@ -0,0 +1,13 @@
++# Check for the existence of FILE.
++AC_DEFUN([AC_CHECK_BUILD_FILE],
++[AS_VAR_PUSHDEF([ac_File], [ac_cv_file_$1])dnl
++AC_CACHE_CHECK([for $1], ac_File,
++[if test -r "$1"; then
++ AS_VAR_SET(ac_File, yes)
++else
++ AS_VAR_SET(ac_File, no)
++fi])
++AS_IF([test AS_VAR_GET(ac_File) = yes], [$2], [$3])[]dnl
++AS_VAR_POPDEF([ac_File])dnl
++])# AC_CHECK_BUILD_FILE
++
diff --git a/recipes/openchrome/openchrome.inc b/recipes/openchrome/openchrome.inc
new file mode 100644
index 0000000000..e88f3223ae
--- /dev/null
+++ b/recipes/openchrome/openchrome.inc
@@ -0,0 +1,16 @@
+PACKAGES = "libviaXvMC libviaXvMCPro libviaXvMC-dev libviaXvMCPro-dev libviaXvMC-dbg libviaXvMCPro-dbg ${PN}-doc"
+
+FILES_libviaXvMC = "${libdir}/libviaXvMC.so.*"
+FILES_libviaXvMCPro = "${libdir}/libviaXvMCPro.so.*"
+FILES_libviaXvMC-dev = "${libdir}/libviaXvMC.so ${libdir}/libviaXvMC.la"
+FILES_libviaXvMCPro-dev = "${libdir}/libviaXvMCPro.so ${libdir}/libviaXvMCPro.la"
+FILES_libviaXvMC-dbg += "${libdir}/.debug/libviaXvMC.so.*"
+FILES_libviaXvMCPro-dbg += "${libdir}/.debug/libviaXvMCPro.so.*"
+
+DEPENDS = "xserver-xorg libxvmc"
+
+inherit autotools xorg-module
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/openchrome/openchrome_svn.bb b/recipes/openchrome/openchrome_svn.bb
new file mode 100644
index 0000000000..c1d8052eea
--- /dev/null
+++ b/recipes/openchrome/openchrome_svn.bb
@@ -0,0 +1,5 @@
+SRC_URI = "svn://svn.openchrome.org/svn;module=trunk;proto=http"
+S = "${WORKDIR}/trunk"
+PACKAGES_DYNAMIC = "xorg-driver-via"
+
+include openchrome.inc
diff --git a/recipes/openchrome/xf86-video-openchrome_0.2.902.bb b/recipes/openchrome/xf86-video-openchrome_0.2.902.bb
new file mode 100644
index 0000000000..5792f72184
--- /dev/null
+++ b/recipes/openchrome/xf86-video-openchrome_0.2.902.bb
@@ -0,0 +1,4 @@
+SRC_URI = "http://www.openchrome.org/releases/xf86-video-openchrome-${PV}.tar.gz file://configure.patch;patch=1 file://configure-dri.patch;patch=1"
+PACKAGES_DYNAMIC = "xorg-driver-openchrome"
+
+include openchrome.inc