summaryrefslogtreecommitdiffstats
path: root/recipes/opencv/opencv_1.0.0.bb
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-23 20:23:53 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:53:41 -0700
commitbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (patch)
tree96f28e2f5133d68c3e3dadabaa2339340671454f /recipes/opencv/opencv_1.0.0.bb
parentfab0af3aefee22b21541e403d3c356a6979bfa63 (diff)
downloadopenembedded-bf7d0467a0788a7fcc1c96e0dc35a25ae09278a0.tar.gz
Rename url params patch=<ignored>/pnum=<n> to apply={yes,no}/striplevel=<n>
I think this makes the behavior rather more clear. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/opencv/opencv_1.0.0.bb')
-rw-r--r--recipes/opencv/opencv_1.0.0.bb36
1 files changed, 18 insertions, 18 deletions
diff --git a/recipes/opencv/opencv_1.0.0.bb b/recipes/opencv/opencv_1.0.0.bb
index 2872d06273..b696323214 100644
--- a/recipes/opencv/opencv_1.0.0.bb
+++ b/recipes/opencv/opencv_1.0.0.bb
@@ -10,24 +10,24 @@ DEPENDS = "libtool swig swig-native python jpeg zlib libpng tiff glib-2.0"
#RDEPENDS = "python jpeg zlib libpng tiff glib-2.0"
SRC_URI = "${SOURCEFORGE_MIRROR}/opencvlibrary/opencv-${PV}.tar.gz \
- file://debian/010_enable_static.diff;patch=1 \
- file://debian/010_ffmpeg_linking.diff;patch=1 \
- file://debian/010_fix_optimisations.diff;patch=1 \
- file://debian/010_m4_syntax.diff;patch=1 \
- file://debian/010_makefile_syntax.diff;patch=1 \
- file://debian/010_python_cspec.diff;patch=1 \
- file://debian/020_python_linking.diff;patch=1 \
- file://debian/030_install_hook.diff;patch=1 \
- file://debian/050_rebootstrap.diff;patch=1 \
- file://debian/100_amd64.diff;patch=1 \
- file://debian/100_static_inline.diff;patch=1 \
- file://debian/100_ffmpeg_updates.diff;patch=1 \
- file://debian/110_dc1394.diff;patch=1 \
- file://debian/120_header_warnings.diff;patch=1 \
- file://debian/200_documentation.diff;patch=1 \
- file://debian/200_examples_makefile.diff;patch=1 \
- file://debian/210_openmp_compilation.diff;patch=1 \
- file://debian/300_fix_segfault_in_window_gtk.diff;patch=1 \
+ file://debian/010_enable_static.diff;apply=yes \
+ file://debian/010_ffmpeg_linking.diff;apply=yes \
+ file://debian/010_fix_optimisations.diff;apply=yes \
+ file://debian/010_m4_syntax.diff;apply=yes \
+ file://debian/010_makefile_syntax.diff;apply=yes \
+ file://debian/010_python_cspec.diff;apply=yes \
+ file://debian/020_python_linking.diff;apply=yes \
+ file://debian/030_install_hook.diff;apply=yes \
+ file://debian/050_rebootstrap.diff;apply=yes \
+ file://debian/100_amd64.diff;apply=yes \
+ file://debian/100_static_inline.diff;apply=yes \
+ file://debian/100_ffmpeg_updates.diff;apply=yes \
+ file://debian/110_dc1394.diff;apply=yes \
+ file://debian/120_header_warnings.diff;apply=yes \
+ file://debian/200_documentation.diff;apply=yes \
+ file://debian/200_examples_makefile.diff;apply=yes \
+ file://debian/210_openmp_compilation.diff;apply=yes \
+ file://debian/300_fix_segfault_in_window_gtk.diff;apply=yes \
"
inherit distutils-base autotools pkgconfig