aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opencv
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-07-08 12:45:24 +0200
committerKoen Kooi <koen@openembedded.org>2010-07-08 12:45:24 +0200
commit73db29022359578bb8a5921c169504d29c5cf9f1 (patch)
tree33051ccacb4f4d674334fbe12f3b884868e2046e /recipes/opencv
parent4551424c80fa2585b61b656642c095dbb7ef3888 (diff)
downloadopenembedded-73db29022359578bb8a5921c169504d29c5cf9f1.tar.gz
openscenegraph: fix GLES2 and ffmpeg build
Diffstat (limited to 'recipes/opencv')
-rw-r--r--recipes/opencv/openscenegraph_2.9.6.bb25
1 files changed, 23 insertions, 2 deletions
diff --git a/recipes/opencv/openscenegraph_2.9.6.bb b/recipes/opencv/openscenegraph_2.9.6.bb
index 0118a460be..a1edf18973 100644
--- a/recipes/opencv/openscenegraph_2.9.6.bb
+++ b/recipes/opencv/openscenegraph_2.9.6.bb
@@ -1,7 +1,9 @@
DESCRIPTION = "The OpenSceneGraph is an open source high performance 3D graphics toolkit"
LICENSE = "OSGPL"
-DEPENDS = "gtk+ ffmpeg poppler libxrandr"
+DEPENDS = "libxml2 gtk+ ffmpeg poppler libxrandr"
+
+PR = "r1"
inherit cmake
@@ -13,7 +15,26 @@ SRC_URI[osg.sha256sum] = "9aa8ce2a581d42f8c9bac14dff5069c66633ddf73370a1e7412873
S = "${WORKDIR}/OpenSceneGraph-${PV}"
-EXTRA_OECMAKE = " -DCMAKE_BUILD_TYPE=Release "
+# From http://www.openscenegraph.org/projects/osg/wiki/Community/OpenGL-ES
+EXTRA_OECMAKE = " -DCMAKE_BUILD_TYPE=Release \
+ -DOSG_GLU_AVAILABLE=OFF \
+ -DOSG_GL1_AVAILABLE=OFF \
+ -DOSG_GL2_AVAILABLE=OFF \
+ -DOSG_GL3_AVAILABLE=OFF \
+ -DOSG_GLES1_AVAILABLE=OFF \
+ -DOSG_GLES2_AVAILABLE=ON \
+ -DOPENGL_egl_LIBRARY='-lEGL -lGLESv2 -lGLES_CM -lIMGegl -lsrv_um' \
+ -DOPENGL_LIBRARY='-lGLESv2 -lGLES_CM -lIMGegl -lsrv_um' \
+ -DOSG_GL_DISPLAYLISTS_AVAILABLE=OFF \
+ -DOSG_GL_MATRICES_AVAILABLE=OFF \
+ -DOSG_GL_VERTEX_FUNCS_AVAILABLE=OFF \
+ -DOSG_GL_VERTEX_ARRAY_FUNCS_AVAILABLE=OFF \
+ -DOSG_GL_FIXED_FUNCTION_AVAILABLE=OFF \
+ -DOSG_CPP_EXCEPTIONS_AVAILABLE=OFF \
+ -DPOPPLER_HAS_CAIRO_EXITCODE=0 \
+ "
+
+TARGET_CC_ARCH += "-D__STDC_CONSTANT_MACROS"
FILES_${PN} = " ${bindir}/* ${libdir}/osgPlugins-${PV}/*.so "
FILES_${PN}-dbg += "${libdir}/osgPlugins-${PV}/.debug"