aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openjade
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-10-17 14:53:26 -0700
committerKhem Raj <raj.khem@gmail.com>2010-10-17 14:55:05 -0700
commitab83ea3d6e6b881480cb6665e9921b65f9b6e682 (patch)
tree33cca82b521c00f7face9d65bf8e36c48ac6c1e7 /recipes/openjade
parent9f2d379829e7e54b217694bce42c0e8d3e4233c5 (diff)
downloadopenembedded-ab83ea3d6e6b881480cb6665e9921b65f9b6e682.tar.gz
openjade_1.3.2.bb: Update configury to make it autreconf'able
* With the autoconf and makefile patches now we can run autreconf and which means the appropriate libtool macros are generated Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/openjade')
-rw-r--r--recipes/openjade/openjade-1.3.2/autoconf.patch170
-rw-r--r--recipes/openjade/openjade-1.3.2/makefile.patch31
-rw-r--r--recipes/openjade/openjade_1.3.2.bb11
3 files changed, 207 insertions, 5 deletions
diff --git a/recipes/openjade/openjade-1.3.2/autoconf.patch b/recipes/openjade/openjade-1.3.2/autoconf.patch
new file mode 100644
index 0000000000..f9fa5293f3
--- /dev/null
+++ b/recipes/openjade/openjade-1.3.2/autoconf.patch
@@ -0,0 +1,170 @@
+-- config/acinclude.m4
++++ config/acinclude.m4 2002/04/08 23:13:37
+@@ -0,0 +1,61 @@
++dnl Configure-time switch with default
++dnl
++dnl Each switch defines an --enable-FOO and --disable-FOO option in
++dnl the resulting configure script.
++dnl
++dnl Usage:
++dnl SMR_SWITCH(name, description, default, pos-def, neg-def)
++dnl
++dnl where:
++dnl
++dnl name name of switch; generates --enable-name & --disable-name
++dnl options
++dnl description help string is set to this prefixed by "enable" or
++dnl "disable", whichever is the non-default value
++dnl default either "on" or "off"; specifies default if neither
++dnl --enable-name nor --disable-name is specified
++dnl pos-def a symbol to AC_DEFINE if switch is on (optional)
++dnl neg-def a symbol to AC_DEFINE if switch is off (optional)
++dnl
++AC_DEFUN(SMR_SWITCH, [
++ AC_MSG_CHECKING(whether to enable $2)
++ AC_ARG_ENABLE(
++ $1,
++ ifelse($3, on,
++ [ --disable-[$1] disable [$2]],
++ [ --enable-[$1] enable [$2]]),
++ [ if test "$enableval" = yes; then
++ AC_MSG_RESULT(yes)
++ ifelse($4, , , AC_DEFINE($4))
++ else
++ AC_MSG_RESULT(no)
++ ifelse($5, , , AC_DEFINE($5))
++ fi ],
++ ifelse($3, on,
++ [ AC_MSG_RESULT(yes)
++ ifelse($4, , , AC_DEFINE($4)) ],
++ [ AC_MSG_RESULT(no)
++ ifelse($5, , , AC_DEFINE($5))]))])
++
++dnl
++dnl Examine size_t and define SIZE_T_IS_UINT, if size_t is an unsigned int
++dnl
++AC_DEFUN(OJ_SIZE_T_IS_UINT,[
++ AC_REQUIRE([AC_TYPE_SIZE_T])
++ AC_MSG_CHECKING(whether size_t is unsigned int)
++ ac_cv_size_t_is_uint=no
++ AC_LANG_SAVE
++ AC_LANG_CPLUSPLUS
++ AC_TRY_COMPILE([#include <unistd.h>
++
++ template<class T> class foo { };
++
++ ], [
++ foo<size_t> x;
++ foo<unsigned int> y;
++ x = y;
++ ],ac_cv_size_t_is_uint=yes)
++ AC_LANG_RESTORE
++ AC_MSG_RESULT($ac_cv_size_t_is_uint)
++ test "$ac_cv_size_t_is_uint" = "yes" && AC_DEFINE(SIZE_T_IS_UINT)
++])
+Index: openjade-1.3.2/config/acinclude.m4
+===================================================================
+--- openjade-1.3.2.orig/config/acinclude.m4
++++ openjade-1.3.2/config/acinclude.m4
+@@ -1,3 +1,64 @@
++dnl Configure-time switch with default
++dnl
++dnl Each switch defines an --enable-FOO and --disable-FOO option in
++dnl the resulting configure script.
++dnl
++dnl Usage:
++dnl SMR_SWITCH(name, description, default, pos-def, neg-def)
++dnl
++dnl where:
++dnl
++dnl name name of switch; generates --enable-name & --disable-name
++dnl options
++dnl description help string is set to this prefixed by "enable" or
++dnl "disable", whichever is the non-default value
++dnl default either "on" or "off"; specifies default if neither
++dnl --enable-name nor --disable-name is specified
++dnl pos-def a symbol to AC_DEFINE if switch is on (optional)
++dnl neg-def a symbol to AC_DEFINE if switch is off (optional)
++dnl
++AC_DEFUN(SMR_SWITCH, [
++ AC_MSG_CHECKING(whether to enable $2)
++ AC_ARG_ENABLE(
++ $1,
++ ifelse($3, on,
++ [ --disable-[$1] disable [$2]],
++ [ --enable-[$1] enable [$2]]),
++ [ if test "$enableval" = yes; then
++ AC_MSG_RESULT(yes)
++ ifelse($4, , , AC_DEFINE($4))
++ else
++ AC_MSG_RESULT(no)
++ ifelse($5, , , AC_DEFINE($5))
++ fi ],
++ ifelse($3, on,
++ [ AC_MSG_RESULT(yes)
++ ifelse($4, , , AC_DEFINE($4)) ],
++ [ AC_MSG_RESULT(no)
++ ifelse($5, , , AC_DEFINE($5))]))])
++
++dnl
++dnl Examine size_t and define SIZE_T_IS_UINT, if size_t is an unsigned int
++dnl
++AC_DEFUN(OJ_SIZE_T_IS_UINT,[
++ AC_REQUIRE([AC_TYPE_SIZE_T])
++ AC_MSG_CHECKING(whether size_t is unsigned int)
++ ac_cv_size_t_is_uint=no
++ AC_LANG_SAVE
++ AC_LANG_CPLUSPLUS
++ AC_TRY_COMPILE([#include <unistd.h>
++
++ template<class T> class foo { };
++
++ ], [
++ foo<size_t> x;
++ foo<unsigned int> y;
++ x = y;
++ ],ac_cv_size_t_is_uint=yes)
++ AC_LANG_RESTORE
++ AC_MSG_RESULT($ac_cv_size_t_is_uint)
++ test "$ac_cv_size_t_is_uint" = "yes" && AC_DEFINE(SIZE_T_IS_UINT)
++])
+ dnl
+ dnl Examine size_t and define SIZE_T_IS_UINT, if size_t is an unsigned int
+ dnl
+Index: openjade-1.3.2/config/aclocal.m4
+===================================================================
+--- openjade-1.3.2.orig/config/aclocal.m4
++++ openjade-1.3.2/config/aclocal.m4
+@@ -3352,7 +3352,7 @@ dnl Each switch defines an --enable-FOO
+ dnl the resulting configure script.
+ dnl
+ dnl Usage:
+-dnl smr_SWITCH(name, description, default, pos-def, neg-def)
++dnl SMR_SWITCH(name, description, default, pos-def, neg-def)
+ dnl
+ dnl where:
+ dnl
+@@ -3365,7 +3365,7 @@ dnl --enable-name nor --disa
+ dnl pos-def a symbol to AC_DEFINE if switch is on (optional)
+ dnl neg-def a symbol to AC_DEFINE if switch is off (optional)
+ dnl
+-AC_DEFUN(smr_SWITCH, [
++AC_DEFUN(SMR_SWITCH, [
+ AC_MSG_CHECKING(whether to enable $2)
+ AC_ARG_ENABLE(
+ $1,
+Index: openjade-1.3.2/config/configure.in
+===================================================================
+--- openjade-1.3.2.orig/config/configure.in
++++ openjade-1.3.2/config/configure.in
+@@ -243,8 +243,8 @@ AC_ARG_ENABLE(http,
+ dnl
+ dnl optional backends
+ dnl
+-smr_SWITCH(mif, support for FrameMaker MIF output, on, JADE_MIF, DUMMY)
+-smr_SWITCH(html, support for HTML+CSS output, on, JADE_HTML, DUMMY)
++SMR_SWITCH(mif, support for FrameMaker MIF output, on, JADE_MIF, DUMMY)
++SMR_SWITCH(html, support for HTML+CSS output, on, JADE_HTML, DUMMY)
+
+
+ dnl
diff --git a/recipes/openjade/openjade-1.3.2/makefile.patch b/recipes/openjade/openjade-1.3.2/makefile.patch
new file mode 100644
index 0000000000..5225fb9f48
--- /dev/null
+++ b/recipes/openjade/openjade-1.3.2/makefile.patch
@@ -0,0 +1,31 @@
+Index: openjade-1.3.2/spgrove/Makefile.sub
+===================================================================
+--- openjade-1.3.2.orig/spgrove/Makefile.sub
++++ openjade-1.3.2/spgrove/Makefile.sub
+@@ -1,8 +1,8 @@
+ LTVERSION=0:1:0
+ LIB=ospgrove
+ INCLUDE=-I$(srcdir)/../grove
+-DEPLIBS=-lm -L$(TOP)/grove -L$(TOP)/grove/.libs \
+- -L$(TOP)/lib -L$(TOP)/lib/.libs \
++DEPLIBS=-lm $(TOP)/grove \
++ $(TOP)/lib \
+ $(LIB_THREADS)
+ OBJS=GroveApp.o GroveBuilder.o SdNode.o
+ GENSRCS=grove_inst.cxx
+Index: openjade-1.3.2/style/Makefile.sub
+===================================================================
+--- openjade-1.3.2.orig/style/Makefile.sub
++++ openjade-1.3.2/style/Makefile.sub
+@@ -1,8 +1,8 @@
+ LTVERSION=0:1:0
+ LIB=ostyle
+-DEPLIBS=-lm -L$(TOP)/grove -L$(TOP)/grove/.libs \
+- -L$(TOP)/lib -L$(TOP)/lib/.libs \
+- -L$(TOP)/spgrove -L$(TOP)/spgrove/.libs
++DEPLIBS=-lm $(TOP)/grove \
++ $(TOP)/lib \
++ $(TOP)/spgrove
+ OBJS=LangObj.o \
+ Collector.o \
+ DssslApp.o \
diff --git a/recipes/openjade/openjade_1.3.2.bb b/recipes/openjade/openjade_1.3.2.bb
index d5e2b5aab8..a84e899d35 100644
--- a/recipes/openjade/openjade_1.3.2.bb
+++ b/recipes/openjade/openjade_1.3.2.bb
@@ -5,9 +5,11 @@ DESCRIPTION = "OpenJade is a suite of tools for validating, \
processing, and applying DSSSL (Document Style Semantics and \
Specification Language) stylesheets to SGML and XML documents."
LICENSE = "BSD"
-PR = "r3"
+PR = "r4"
SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/openjade-${PV}.tar.gz \
file://configure.patch \
+ file://autoconf.patch \
+ file://makefile.patch \
"
SRC_URI_append_virtclass-native = " file://oj-native-libosp-fix.patch"
@@ -22,11 +24,10 @@ acpaths = "-I ${S}/config"
# up, resulting in a fail in do_configure.
CFLAGS_prepend = "-I${S}/include "
-do_configure () {
- cp config/configure.in .
- gnu-configize
- oe_runconf
+do_configure_append () {
+ cp config/configure.in .
}
+
do_install_append () {
# Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/openjade.html
# for details.