summaryrefslogtreecommitdiffstats
path: root/recipes/openmoko-projects/illume-theme-asu_svn.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/openmoko-projects/illume-theme-asu_svn.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/openmoko-projects/illume-theme-asu_svn.bb')
-rw-r--r--recipes/openmoko-projects/illume-theme-asu_svn.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes/openmoko-projects/illume-theme-asu_svn.bb b/recipes/openmoko-projects/illume-theme-asu_svn.bb
new file mode 100644
index 0000000000..e232dbb554
--- /dev/null
+++ b/recipes/openmoko-projects/illume-theme-asu_svn.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Illume - Mobile UI module for Enlightenment"
+HOMEPAGE = "http://illume.projects.openmoko.org/"
+LICENSE = "MIT/BSD"
+DEPENDS = "edje-native eet-native"
+RPROVIDES_${PN} = "illume-theme"
+RCONFLICTS = "illume-config"
+PV = "0.0+svnr${SRCREV}"
+PR = "r9"
+
+SRC_URI = "svn://svn.openmoko.org/trunk/src/target/themes/;module=illume-theme-asu;proto=http"
+
+S = "${WORKDIR}/illume-theme-asu"
+
+do_compile() {
+ cd misc-data/asu && ./build.sh && cd ../..
+ cd misc-data/asu_init && ./build.sh && cd ../..
+ cd config
+ eet -e e.cfg config e.src 1
+ eet -e module.battery.cfg config module.battery.src 1
+ eet -e module.illume.cfg config module.illume.src 1
+}
+
+do_install() {
+ install -d ${D}${sysconfdir}/enlightenment
+ install -d ${D}${datadir}/enlightenment/data/themes
+ install -d ${D}${datadir}/enlightenment/data/init
+ install -d ${D}${datadir}/enlightenment/data/config/asu
+ # Make asu the default profile
+ echo 'E_PROFILE="-profile asu"' > ${D}${sysconfdir}/enlightenment/default_profile
+ install -m 0644 ${S}/misc-data/asu/asu.edj ${D}${datadir}/enlightenment/data/themes/asu.edj
+ install -m 0644 ${S}/misc-data/asu_init/asu_init.edj ${D}${datadir}/enlightenment/data/init/asu_init.edj
+ install -m 0644 ${S}/config/*.cfg ${D}${datadir}/enlightenment/data/config/asu
+}
+
+PACKAGE_ARCH_${PN} = "all"
+PACKAGES = "\
+ ${PN} \
+"
+FILES_${PN} = "${sysconfdir}/enlightenment ${datadir}/enlightenment"
+
+CONFFILES_${PN} = "${sysconfdir}/enlightenment/default_profile"