aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openmoko-tools
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/openmoko-tools
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/openmoko-tools')
-rw-r--r--recipes/openmoko-tools/app-restarter_svn.bb20
-rw-r--r--recipes/openmoko-tools/openmoko-set-root-password.bb26
-rw-r--r--recipes/openmoko-tools/openmoko-toolchain-scripts_svn.bb22
3 files changed, 68 insertions, 0 deletions
diff --git a/recipes/openmoko-tools/app-restarter_svn.bb b/recipes/openmoko-tools/app-restarter_svn.bb
new file mode 100644
index 0000000000..61b68b5173
--- /dev/null
+++ b/recipes/openmoko-tools/app-restarter_svn.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Small utility to restart a crashing application"
+LICENSE = "GPL"
+DEPENDS = "virtual/libx11"
+
+SRC_URI="svn://svn.openmoko.org/developers/zecke/;module=app_restarter;proto=http"
+S = "${WORKDIR}/app_restarter"
+PV = "1.0+svnr${SRCREV}"
+PE = "2"
+
+inherit pkgconfig
+
+do_compile() {
+ cd ${S}
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/app_restarter ${D}/${bindir}/${PN}
+}
diff --git a/recipes/openmoko-tools/openmoko-set-root-password.bb b/recipes/openmoko-tools/openmoko-set-root-password.bb
new file mode 100644
index 0000000000..55ed090da2
--- /dev/null
+++ b/recipes/openmoko-tools/openmoko-set-root-password.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Set a root password for your Neo."
+SUMMARY = "On installation you will be prompted to set a root password. With \
+this password you can then log into the machine."
+LICENSE = "GPL"
+DEPENDS = "gtk+"
+
+SRC_URI = "svn://svn.openmoko.org/developers/zecke/;module=root-password;proto=http"
+S = "${WORKDIR}/root-password"
+PV = "1.0+svnr${SRCREV}"
+PE = "1"
+PR = "r1"
+
+do_compile () {
+ cd ${S}
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -m 0755 ${S}/root-password ${D}/${sbindir}/${PN}
+}
+
+pkg_postinst_${PN} () {
+ # assume we use display 0
+ DISPLAY=:0 ${sbindir}/${PN}
+}
diff --git a/recipes/openmoko-tools/openmoko-toolchain-scripts_svn.bb b/recipes/openmoko-tools/openmoko-toolchain-scripts_svn.bb
new file mode 100644
index 0000000000..e30d66b58a
--- /dev/null
+++ b/recipes/openmoko-tools/openmoko-toolchain-scripts_svn.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Convenient scripts to be used with openmoko toolchain."
+
+PV = "0.0+svnr${SRCREV}"
+PE = "1"
+PR = "r1"
+
+SRC_URI = "svn://svn.openmoko.org/trunk/src/host;module=toolchain-scripts;proto=http"
+
+S = "${WORKDIR}/toolchain-scripts"
+
+do_install () {
+ install -d ${D}/${prefix}
+ cp -dr ${S}/* ${D}/${prefix}
+ find ${D} -name ".svn" | xargs rm -rf
+ rm -rf ${D}/${prefix}/patches
+}
+
+PACKAGE_ARCH = "all"
+
+FILES_${PN} = "/*"
+
+inherit sdk