aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openntpd/openntpd_3.7p1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/openntpd/openntpd_3.7p1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/openntpd/openntpd_3.7p1.bb')
-rw-r--r--recipes/openntpd/openntpd_3.7p1.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes/openntpd/openntpd_3.7p1.bb b/recipes/openntpd/openntpd_3.7p1.bb
new file mode 100644
index 0000000000..b8dca0c278
--- /dev/null
+++ b/recipes/openntpd/openntpd_3.7p1.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "OpenNTPD is a FREE, easy to use implementation of the \
+Network Time Protocol."
+HOMEPAGE = "http://www.openntpd.org/"
+SECTION = "console/network"
+LICENSE = "BSD"
+DEPENDS += "openssl tzdata"
+PR = "r14"
+
+SRC_URI = "http://www.zip.com.au/~dtucker/openntpd/release/openntpd-${PV}.tar.gz \
+ file://autofoo.patch;patch=1 \
+ file://adjtimex-${PV}.patch;patch=1 \
+ file://makefile-install.patch;patch=1 \
+ file://init"
+
+S = "${WORKDIR}/openntpd-${PV}"
+
+inherit autotools update-rc.d
+
+EXTRA_OECONF += "CFLAGS=-DUSE_ADJTIMEX --disable-strip --prefix=/usr \
+ --sysconfdir=/etc --with-privsep-path=/${localstatedir}/shared/empty \
+ --with-privsep-user=ntpd \
+ --with-builtin-arc4random \
+ --without-ssl-dir"
+
+do_install_prepend() {
+ install -d ${D}${sysconfdir}/init.d
+}
+do_install_append() {
+ install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/openntpd
+}
+
+pkg_postinst () {
+ [ ! -d ${localstatedir}/shared ] && mkdir -p ${localstatedir}/shared
+ grep ntpd ${sysconfdir}/passwd || adduser --disabled-password --home=${localstatedir}/shared/empty --ingroup nogroup ntpd
+ chown root:root ${localstatedir}/shared/empty
+}
+
+pkg_postrm () {
+ grep ntpd ${sysconfdir}/passwd && deluser ntpd
+}
+
+INITSCRIPT_NAME = "openntpd"
+
+INITSCRIPT_PARAMS = "defaults"