aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openobex
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/openobex
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/openobex')
-rw-r--r--recipes/openobex/files/disable-cable-test.patch16
-rw-r--r--recipes/openobex/files/libusb_crosscompile_check.patch12
-rw-r--r--recipes/openobex/openobex-1.3/libusb_crosscompile_check.patch11
-rw-r--r--recipes/openobex/openobex_1.2.bb33
-rw-r--r--recipes/openobex/openobex_1.3.bb28
5 files changed, 100 insertions, 0 deletions
diff --git a/recipes/openobex/files/disable-cable-test.patch b/recipes/openobex/files/disable-cable-test.patch
new file mode 100644
index 0000000000..95b636dd8f
--- /dev/null
+++ b/recipes/openobex/files/disable-cable-test.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- openobex-1.2/apps/Makefile.am~disable-cable-test
++++ openobex-1.2/apps/Makefile.am
+@@ -6,7 +6,7 @@
+ obex_io.c obex_io.h \
+ obex_put_common.c obex_put_common.h
+
+-bin_PROGRAMS = irxfer obex_tcp irobex_palm3 obex_test
++bin_PROGRAMS = irxfer obex_tcp irobex_palm3
+
+ obex_test_SOURCES = \
+ obex_test.c obex_test.h \
diff --git a/recipes/openobex/files/libusb_crosscompile_check.patch b/recipes/openobex/files/libusb_crosscompile_check.patch
new file mode 100644
index 0000000000..c28921b8ca
--- /dev/null
+++ b/recipes/openobex/files/libusb_crosscompile_check.patch
@@ -0,0 +1,12 @@
+diff -Naur openobex-1.2_old/acinclude.m4 openobex-1.2/acinclude.m4
+--- openobex-1.2_old/acinclude.m4 2006-03-07 19:57:49.000000000 +0200
++++ openobex-1.2/acinclude.m4 2006-04-18 23:07:25.000000000 +0300
+@@ -195,7 +195,7 @@
+
+ if (test "${usb_enable}" = "yes" && test "${usb_found}" = "yes"); then
+ AC_DEFINE(HAVE_USB, 1, [Define if system supports USB and it's enabled])
+- AC_CHECK_FILE(${usb_prefix}/lib/pkgconfig/libusb.pc, REQUIRES="$REQUIRES libusb")
++ REQUIRES="libusb"
+ fi
+
+ AM_CONDITIONAL(APPS, test "${apps_enable}" = "yes")
diff --git a/recipes/openobex/openobex-1.3/libusb_crosscompile_check.patch b/recipes/openobex/openobex-1.3/libusb_crosscompile_check.patch
new file mode 100644
index 0000000000..ca5bc0041a
--- /dev/null
+++ b/recipes/openobex/openobex-1.3/libusb_crosscompile_check.patch
@@ -0,0 +1,11 @@
+--- /tmp/acinclude.m4 2007-07-19 15:11:49.000000000 +0200
++++ openobex-1.3/acinclude.m4 2007-07-19 15:13:06.925215000 +0200
+@@ -128,7 +128,7 @@
+
+ if (test "${usb_enable}" = "yes" && test "${usb_found}" = "yes"); then
+ AC_DEFINE(HAVE_USB, 1, [Define if system supports USB and it's enabled])
+- AC_CHECK_FILE(${prefix}/lib/pkgconfig/libusb.pc, REQUIRES="$REQUIRES libusb")
++ REQUIRES="libusb"
+ fi
+
+ AM_CONDITIONAL(APPS, test "${apps_enable}" = "yes")
diff --git a/recipes/openobex/openobex_1.2.bb b/recipes/openobex/openobex_1.2.bb
new file mode 100644
index 0000000000..41648ca412
--- /dev/null
+++ b/recipes/openobex/openobex_1.2.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "The Openobex project is an open source implementation of the \
+Object Exchange (OBEX) protocol."
+HOMEPAGE = "http://openobex.triq.net"
+SECTION = "libs"
+PROVIDES = "openobex-apps"
+DEPENDS = "libusb bluez-libs"
+LICENSE = "GPL"
+PR = "r5"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/openobex-${PV}.tar.gz \
+ file://disable-cable-test.patch;patch=1 \
+ file://libusb_crosscompile_check.patch;patch=1"
+
+inherit autotools binconfig pkgconfig
+
+EXTRA_OECONF = "--enable-apps --enable-syslog --enable-dump \
+ --with-usb=${STAGING_LIBDIR}/.. --with-bluez=${STAGING_LIBDIR}/.."
+
+do_stage() {
+ oe_libinstall -so -C lib libopenobex ${STAGING_LIBDIR}
+ ln -sf libopenobex.so ${STAGING_LIBDIR}/libopenobex-1.2.so
+ install -d ${STAGING_INCDIR}/openobex
+ install -m 0644 include/*.h ${STAGING_INCDIR}/openobex/
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 openobex.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+# how to stop shlibrename from renaming -apps?
+PACKAGES += "openobex-apps"
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}/openobex-config"
+FILES_${PN}-apps = "${bindir}/*"
+DEBIAN_NOAUTONAME_${PN}-apps = "1"
diff --git a/recipes/openobex/openobex_1.3.bb b/recipes/openobex/openobex_1.3.bb
new file mode 100644
index 0000000000..65e98e4ab1
--- /dev/null
+++ b/recipes/openobex/openobex_1.3.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "The Openobex project is an open source implementation of the \
+Object Exchange (OBEX) protocol."
+HOMEPAGE = "http://openobex.triq.net"
+SECTION = "libs"
+PROVIDES = "openobex-apps"
+DEPENDS = "libusb bluez-libs"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/openobex-${PV}.tar.gz \
+ file://disable-cable-test.patch;patch=1 \
+ file://libusb_crosscompile_check.patch;patch=1"
+
+inherit autotools binconfig pkgconfig
+
+EXTRA_OECONF = "--enable-apps --enable-syslog --enable-dump \
+ --with-usb=${STAGING_LIBDIR}/.. --with-bluez=${STAGING_LIBDIR}/.."
+
+do_stage() {
+ autotools_stage_all
+}
+
+# how to stop shlibrename from renaming -apps?
+PACKAGES += "openobex-apps"
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}/openobex-config"
+FILES_${PN}-apps = "${bindir}/*"
+DEBIAN_NOAUTONAME_${PN}-apps = "1"