summaryrefslogtreecommitdiffstats
path: root/recipes/openobex
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2009-05-10 23:04:49 -0500
committerMike Westerhof <mwester@dls.net>2009-05-10 23:04:49 -0500
commit6144619ef3fe1df5a562e63de12144ef99f3a503 (patch)
tree641828497e6192e50e5d3b439c220440cc419408 /recipes/openobex
parentd36c7304a4ec4da87bc541bd6930525cf90d6f06 (diff)
downloadopenembedded-6144619ef3fe1df5a562e63de12144ef99f3a503.tar.gz
openobex_1.5.bb: fix missing openobex.m4 file in staging.
Diffstat (limited to 'recipes/openobex')
-rw-r--r--recipes/openobex/openobex_1.5.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes/openobex/openobex_1.5.bb b/recipes/openobex/openobex_1.5.bb
index ab69cf18e9..faa6c066ec 100644
--- a/recipes/openobex/openobex_1.5.bb
+++ b/recipes/openobex/openobex_1.5.bb
@@ -5,6 +5,7 @@ SECTION = "libs"
PROVIDES = "openobex-apps"
DEPENDS = "libusb-compat bluez4"
LICENSE = "GPL"
+PR = "r1"
SRC_URI = "http://www.kernel.org/pub/linux/bluetooth/openobex-${PV}.tar.gz \
file://disable-cable-test.patch;patch=1 \
@@ -15,6 +16,11 @@ inherit autotools_stage binconfig pkgconfig
EXTRA_OECONF = "--enable-apps --enable-syslog --enable-dump \
--with-usb=${STAGING_LIBDIR}/.. --with-bluez=${STAGING_LIBDIR}/.."
+do_stage_append() {
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 ${S}/openobex.m4 ${STAGING_DATADIR}/aclocal
+}
+
PACKAGES += "openobex-apps"
FILES_${PN} = "${libdir}/lib*.so.*"
FILES_${PN}-dev += "${bindir}/openobex-config"