summaryrefslogtreecommitdiffstats
path: root/recipes/openocd
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/openocd
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/openocd')
-rw-r--r--recipes/openocd/files/openocd-link-static.patch20
-rw-r--r--recipes/openocd/openocd-native_svn.bb17
-rw-r--r--recipes/openocd/openocd_svn.bb14
3 files changed, 51 insertions, 0 deletions
diff --git a/recipes/openocd/files/openocd-link-static.patch b/recipes/openocd/files/openocd-link-static.patch
new file mode 100644
index 0000000000..8a686efe5d
--- /dev/null
+++ b/recipes/openocd/files/openocd-link-static.patch
@@ -0,0 +1,20 @@
+--- openocd/src/Makefile.am.orig 2007-03-01 11:51:41.000000000 -0300
++++ openocd/src/Makefile.am 2007-03-01 11:58:08.000000000 -0300
+@@ -7,7 +7,7 @@
+ -I$(top_srcdir)/src/flash -I$(top_srcdir)/src/pld $(all_includes)
+
+ # the library search path.
+-openocd_LDFLAGS = $(all_libraries)
++openocd_LDFLAGS = -static $(all_libraries)
+ SUBDIRS = helper jtag xsvf target server flash pld
+
+ if IS_MINGW
+@@ -17,7 +17,7 @@
+ endif
+
+ if FT2232_LIBFTDI
+-FTDI2232LIB = -lftdi
++FTDI2232LIB = -lftdi -lusb
+ else
+ FTDI2232LIB =
+ endif
diff --git a/recipes/openocd/openocd-native_svn.bb b/recipes/openocd/openocd-native_svn.bb
new file mode 100644
index 0000000000..3ca688b5c3
--- /dev/null
+++ b/recipes/openocd/openocd-native_svn.bb
@@ -0,0 +1,17 @@
+require openocd_${PV}.bb
+
+inherit native
+
+DEPENDS = "libftdi-native"
+EXTRA_OECONF = "--enable-ft2232_libftdi --enable-parport-ppdev"
+
+do_stage() {
+ install -m 0755 src/openocd ${STAGING_BINDIR_NATIVE}
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_TOOLS}
+ install -m 0755 src/openocd ${DEPLOY_DIR_TOOLS}/openocd-${PV}
+}
+
+addtask deploy before do_package after do_install
diff --git a/recipes/openocd/openocd_svn.bb b/recipes/openocd/openocd_svn.bb
new file mode 100644
index 0000000000..6823eabb98
--- /dev/null
+++ b/recipes/openocd/openocd_svn.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Free and Open On-Chip Debugging, In-System Programming and Boundary-Scan Testing"
+HOMEPAGE = "http://openocd.berlios.de/"
+LICENSE = "GPL"
+PV = "0.0+svnr${SRCREV}"
+PR = "r3"
+
+inherit autotools
+
+SRC_URI = "svn://svn.berlios.de/openocd;module=trunk \
+ file://openocd-link-static.patch;patch=1"
+S = "${WORKDIR}/trunk"
+
+DEPENDS = "libftdi"
+EXTRA_OECONF = " --enable-ft2232_libftdi --disable-ftdi2232 --disable-ftd2xx"