aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openssl
diff options
context:
space:
mode:
authorMichael Smith <msmith@cbnco.com>2009-08-12 01:21:49 -0400
committerMichael Smith <msmith@cbnco.com>2009-09-01 18:01:48 -0400
commitaf431dbe673e2135f912d07479e4b964f5583246 (patch)
tree1c5466b1441d8b97c3943731b8e10b328b6e1c1d /recipes/openssl
parenta5c9970599cbfe15b776cbb57cb9b1b06fbdcb1c (diff)
downloadopenembedded-af431dbe673e2135f912d07479e4b964f5583246.tar.gz
openssl.inc: fix packaging on x86_64; use INC_PR
openssl's makefile always installs to ${prefix}/lib, even if libdir is ${prefix}/lib64. Move some files around to make it fit. Signed-off-by: Michael Smith <msmith@cbnco.com>
Diffstat (limited to 'recipes/openssl')
-rw-r--r--recipes/openssl/openssl-native_0.9.7g.bb2
-rw-r--r--recipes/openssl/openssl-native_0.9.7m.bb2
-rw-r--r--recipes/openssl/openssl-native_0.9.8g.bb2
-rw-r--r--recipes/openssl/openssl-native_0.9.8j.bb2
-rw-r--r--recipes/openssl/openssl.inc13
-rw-r--r--recipes/openssl/openssl_0.9.7e.bb2
-rw-r--r--recipes/openssl/openssl_0.9.7g.bb2
-rw-r--r--recipes/openssl/openssl_0.9.7m.bb2
-rw-r--r--recipes/openssl/openssl_0.9.8g.bb2
-rw-r--r--recipes/openssl/openssl_0.9.8j.bb2
10 files changed, 20 insertions, 11 deletions
diff --git a/recipes/openssl/openssl-native_0.9.7g.bb b/recipes/openssl/openssl-native_0.9.7g.bb
index dfe3ab5eae..40558f2cdb 100644
--- a/recipes/openssl/openssl-native_0.9.7g.bb
+++ b/recipes/openssl/openssl-native_0.9.7g.bb
@@ -2,7 +2,7 @@ inherit pkgconfig native
require openssl.inc
-PR = "r2"
+PR = "${INC_PR}.0"
SRC_URI += "file://debian.patch;patch=1 \
file://armeb.patch;patch=1;pnum=0 \
diff --git a/recipes/openssl/openssl-native_0.9.7m.bb b/recipes/openssl/openssl-native_0.9.7m.bb
index 445b6e9161..ccae43e629 100644
--- a/recipes/openssl/openssl-native_0.9.7m.bb
+++ b/recipes/openssl/openssl-native_0.9.7m.bb
@@ -6,7 +6,7 @@ require openssl.inc
export FULL_OPTIMIZATION = " "
export BUILD_OPTIMIZATION = " "
-PR = "r2"
+PR = "${INC_PR}.0"
SRC_URI += "file://debian.patch;patch=1 \
file://armeb.patch;patch=1;pnum=0 \
diff --git a/recipes/openssl/openssl-native_0.9.8g.bb b/recipes/openssl/openssl-native_0.9.8g.bb
index 27f0169cf9..d567ae73f9 100644
--- a/recipes/openssl/openssl-native_0.9.8g.bb
+++ b/recipes/openssl/openssl-native_0.9.8g.bb
@@ -2,7 +2,7 @@ inherit pkgconfig native
require openssl.inc
-PR = "r1"
+PR = "${INC_PR}.0"
# This flag can contain target options (e.g -mfpu=neon for armv7-a systems)
export FULL_OPTIMIZATION = " "
diff --git a/recipes/openssl/openssl-native_0.9.8j.bb b/recipes/openssl/openssl-native_0.9.8j.bb
index ffbd5ea8a9..976a4d7835 100644
--- a/recipes/openssl/openssl-native_0.9.8j.bb
+++ b/recipes/openssl/openssl-native_0.9.8j.bb
@@ -2,7 +2,7 @@ inherit pkgconfig native
require openssl.inc
-PR = "r1"
+PR = "${INC_PR}.0"
# This flag can contain target options (e.g -mfpu=neon for armv7-a systems)
export FULL_OPTIMIZATION = " "
diff --git a/recipes/openssl/openssl.inc b/recipes/openssl/openssl.inc
index 3972cd3bd9..fea05f84e9 100644
--- a/recipes/openssl/openssl.inc
+++ b/recipes/openssl/openssl.inc
@@ -6,6 +6,8 @@ SECTION = "libs/network"
SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz"
S = "${WORKDIR}/openssl-${PV}"
+INC_PR = "r10"
+
AR_append = " r"
CFLAG = "${@base_conditional('SITEINFO_ENDIANESS', 'le', '-DL_ENDIAN', '-DB_ENDIAN', d)} \
-DTERMIO ${FULL_OPTIMIZATION} -Wall"
@@ -94,9 +96,16 @@ do_stage () {
}
do_install () {
- install -m 0755 -d ${D}${libdir}/pkgconfig
oe_runmake INSTALL_PREFIX="${D}" install
- chmod 644 ${D}${libdir}/pkgconfig/openssl.pc
+
+ # On x86_64, move lib/* to lib64
+ if [ "${libdir}" != "${prefix}/lib" ]
+ then
+ install -d ${D}${libdir} ${D}${libdir}/pkgconfig
+ mv ${D}${prefix}/lib/lib* ${D}${libdir}
+ mv ${D}${prefix}/lib/pkgconfig/*.pc ${D}${libdir}/pkgconfig
+ fi
+
oe_libinstall -so libcrypto ${D}${libdir}
oe_libinstall -so libssl ${D}${libdir}
}
diff --git a/recipes/openssl/openssl_0.9.7e.bb b/recipes/openssl/openssl_0.9.7e.bb
index cda364a53d..b82107661b 100644
--- a/recipes/openssl/openssl_0.9.7e.bb
+++ b/recipes/openssl/openssl_0.9.7e.bb
@@ -1,6 +1,6 @@
require openssl.inc
-PR = "r6"
+PR = "${INC_PR}.0"
SRC_URI += "file://debian.patch;patch=1 \
file://armeb.patch;patch=1 \
diff --git a/recipes/openssl/openssl_0.9.7g.bb b/recipes/openssl/openssl_0.9.7g.bb
index fbd2af26f9..68a26147c6 100644
--- a/recipes/openssl/openssl_0.9.7g.bb
+++ b/recipes/openssl/openssl_0.9.7g.bb
@@ -2,7 +2,7 @@ inherit pkgconfig
require openssl.inc
-PR = "r7"
+PR = "${INC_PR}.0"
SRC_URI += "file://debian.patch;patch=1 \
file://armeb.patch;patch=1;pnum=0 \
diff --git a/recipes/openssl/openssl_0.9.7m.bb b/recipes/openssl/openssl_0.9.7m.bb
index fbd2af26f9..68a26147c6 100644
--- a/recipes/openssl/openssl_0.9.7m.bb
+++ b/recipes/openssl/openssl_0.9.7m.bb
@@ -2,7 +2,7 @@ inherit pkgconfig
require openssl.inc
-PR = "r7"
+PR = "${INC_PR}.0"
SRC_URI += "file://debian.patch;patch=1 \
file://armeb.patch;patch=1;pnum=0 \
diff --git a/recipes/openssl/openssl_0.9.8g.bb b/recipes/openssl/openssl_0.9.8g.bb
index 1cb360f967..d76e756c14 100644
--- a/recipes/openssl/openssl_0.9.8g.bb
+++ b/recipes/openssl/openssl_0.9.8g.bb
@@ -2,7 +2,7 @@ inherit pkgconfig
require openssl.inc
-PR = "r9"
+PR = "${INC_PR}.0"
SRC_URI += "file://debian.patch;patch=1 \
file://configure-targets.patch;patch=1 \
diff --git a/recipes/openssl/openssl_0.9.8j.bb b/recipes/openssl/openssl_0.9.8j.bb
index 21450d2a24..bb9694f618 100644
--- a/recipes/openssl/openssl_0.9.8j.bb
+++ b/recipes/openssl/openssl_0.9.8j.bb
@@ -2,7 +2,7 @@ inherit pkgconfig
require openssl.inc
-PR = "r2"
+PR = "${INC_PR}.0"
export OE_LDFLAGS="${LDFLAGS}"