aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openswan
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2011-01-28 20:53:28 -0500
committerChris Larson <chris_larson@mentor.com>2011-01-28 20:53:43 -0500
commit84f0a42594111f6f6ddf57f5925cd7848be31ee9 (patch)
tree9dc10e69b473d5acea3860c5502b4881f383c9b6 /recipes/openswan
parent2dac84b9a7b820466ed626420fec120093b56e16 (diff)
downloadopenembedded-84f0a42594111f6f6ddf57f5925cd7848be31ee9.tar.gz
openswan: fix build with install wrapper
Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'recipes/openswan')
-rw-r--r--recipes/openswan/openswan-2.6.31/installcmd.patch17
-rw-r--r--recipes/openswan/openswan_2.6.31.bb9
2 files changed, 22 insertions, 4 deletions
diff --git a/recipes/openswan/openswan-2.6.31/installcmd.patch b/recipes/openswan/openswan-2.6.31/installcmd.patch
new file mode 100644
index 0000000000..432757abb3
--- /dev/null
+++ b/recipes/openswan/openswan-2.6.31/installcmd.patch
@@ -0,0 +1,17 @@
+---
+ Makefile.inc | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- openswan-2.6.31.orig/Makefile.inc
++++ openswan-2.6.31/Makefile.inc
+@@ -163,8 +163,8 @@ INSTALL=install
+ # how backup names are composed.
+ # Note that the install procedures will never overwrite an existing config
+ # file, which is why -b is not specified for them.
+-INSTBINFLAGS=-b --suffix=.old
+-INSTSUIDFLAGS=--mode=u+rxs,g+rx,o+rx --group=root -b --suffix=.old
++INSTBINFLAGS=-b
++INSTSUIDFLAGS=-m u+rxs,g+rx,o+rx -g root -b
+ INSTMANFLAGS=
+ INSTCONFFLAGS=
+ # For OSX use
diff --git a/recipes/openswan/openswan_2.6.31.bb b/recipes/openswan/openswan_2.6.31.bb
index bae05d238b..cf7c3a762c 100644
--- a/recipes/openswan/openswan_2.6.31.bb
+++ b/recipes/openswan/openswan_2.6.31.bb
@@ -6,14 +6,15 @@ LICENSE = "GPLv2"
DEPENDS = "gmp flex-native bison-native"
RRECOMMENDS_${PN} = "kernel-module-ipsec"
RDEPENDS_append_nylon = "perl"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://www.openswan.org/download/openswan-${PV}.tar.gz \
- file://fix-parser-build-race.patch"
+ file://fix-parser-build-race.patch \
+ file://installcmd.patch"
EXTRA_OEMAKE = "DESTDIR=${D} \
- USERCOMPILE="${CFLAGS}" \
- USERLINK="${LDFLAGS}" \
+ USERCOMPILE='${CFLAGS}' \
+ USERLINK='${LDFLAGS}' \
FINALCONFDIR=${sysconfdir}/ipsec \
FINALLIBDIR=${libdir}/ipsec \
FINALLIBEXECDIR=${libexecdir}/ipsec \