aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openswan
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-10-01 17:47:34 -0700
committerTom Rini <tom_rini@mentor.com>2010-10-01 18:25:36 -0700
commitaee8e647ee70819f6d920c35641500e857c65035 (patch)
treeeb4f3eba762877567513ab9b6f603d1ce357597e /recipes/openswan
parent02a2b0dcb85c7165cf615545f5ae21d3f35c6450 (diff)
downloadopenembedded-aee8e647ee70819f6d920c35641500e857c65035.tar.gz
openswan: getline rename, from Gentoo
Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/openswan')
-rw-r--r--recipes/openswan/openswan-2.4.7/openswan-2.4.14-getline.patch45
-rw-r--r--recipes/openswan/openswan_2.4.7.bb5
2 files changed, 48 insertions, 2 deletions
diff --git a/recipes/openswan/openswan-2.4.7/openswan-2.4.14-getline.patch b/recipes/openswan/openswan-2.4.7/openswan-2.4.14-getline.patch
new file mode 100644
index 0000000000..c183eec9e4
--- /dev/null
+++ b/recipes/openswan/openswan-2.4.7/openswan-2.4.14-getline.patch
@@ -0,0 +1,45 @@
+Taken from https://bugs.gentoo.org/show_bug.cgi?id=271987
+
+diff -Nru openswan-2.4.14.orig/lib/libopenswan/optionsfrom.c openswan-2.4.14/lib/libopenswan/optionsfrom.c
+--- openswan-2.4.14.orig/lib/libopenswan/optionsfrom.c 2004-04-09 21:00:38.000000000 +0300
++++ openswan-2.4.14/lib/libopenswan/optionsfrom.c 2009-06-01 22:21:56.000000000 +0300
+@@ -31,7 +31,7 @@
+
+ static const char *dowork(const char *, int *, char ***, int);
+ static const char *getanarg(FILE *, struct work *, char **);
+-static char *getline(FILE *, char *, size_t);
++static char *osw_getline(FILE *, char *, size_t);
+
+ /*
+ - optionsfrom - add some options, taken from a file, to argc/argv
+@@ -149,7 +149,7 @@
+ char *endp;
+
+ while (w->pending == NULL) { /* no pending line */
+- if ((w->line = getline(f, w->buf, sizeof(w->buf))) == NULL)
++ if ((w->line = osw_getline(f, w->buf, sizeof(w->buf))) == NULL)
+ return "error in line read"; /* caller checks EOF */
+ if (w->line[0] != '#' &&
+ *(w->line + strspn(w->line, " \t")) != '\0')
+@@ -171,7 +171,7 @@
+ if (*linep == NULL)
+ return "out of memory for new line";
+ strcpy(*linep, p);
+- } else /* getline already malloced it */
++ } else /* osw_getline already malloced it */
+ *linep = p;
+ return NULL;
+ }
+@@ -203,10 +203,10 @@
+ }
+
+ /*
+- - getline - read a line from the file, trim newline off
++ - osw_getline - read a line from the file, trim newline off
+ */
+ static char * /* pointer to line, NULL for eof/error */
+-getline(f, buf, bufsize)
++osw_getline(f, buf, bufsize)
+ FILE *f;
+ char *buf; /* buffer to use, if convenient */
+ size_t bufsize; /* size of buf */
diff --git a/recipes/openswan/openswan_2.4.7.bb b/recipes/openswan/openswan_2.4.7.bb
index d9d994c908..5aefb45dd3 100644
--- a/recipes/openswan/openswan_2.4.7.bb
+++ b/recipes/openswan/openswan_2.4.7.bb
@@ -6,12 +6,13 @@ LICENSE = "GPLv2"
DEPENDS = "gmp flex-native"
RRECOMMENDS_${PN} = "kernel-module-ipsec"
RDEPENDS_append_nylon = "perl"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://www.openswan.org/download/openswan-${PV}.tar.gz \
file://openswan-2.4.7-gentoo.patch \
file://installflags.patch \
- file://ld-library-path-breakage.patch"
+ file://ld-library-path-breakage.patch \
+ file://openswan-2.4.14-getline.patch"
S = "${WORKDIR}/openswan-${PV}"
PARALLEL_MAKE = ""