aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opensync/wbxml2_0.9.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/opensync/wbxml2_0.9.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/opensync/wbxml2_0.9.2.bb')
-rw-r--r--recipes/opensync/wbxml2_0.9.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/opensync/wbxml2_0.9.2.bb b/recipes/opensync/wbxml2_0.9.2.bb
new file mode 100644
index 0000000000..a45e1c6d66
--- /dev/null
+++ b/recipes/opensync/wbxml2_0.9.2.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "WBXML parsing and encoding library"
+LICENSE = "LGPL"
+
+DEPENDS = "expat popt"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/wbxmllib/${PN}-${PV}.tar.gz \
+ file://00-fix-includes.patch;patch=1 \
+ file://01-anonymous-support-and-misc-fixes.patch;patch=1 \
+ file://02-namespaces.patch;patch=1 \
+ file://04_saxlike_entity_parsing.patch;patch=1 \
+ file://05-syncml-fixes.patch;patch=1 \
+ file://06-no-install-docs.patch;patch=1 \
+ file://07-current_attr_null.patch;patch=1 \
+ file://08-maxsize-translation-table.patch;patch=1;pnum=0 \
+ "
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES += "${PN}-tools"
+
+FILES_${PN}-tools = "${bindir}"
+FILES_${PN} = "${libdir}/*.so.*"
+
+
+