aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opentom
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/opentom
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/opentom')
-rw-r--r--recipes/opentom/ttimgextract.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/opentom/ttimgextract.bb b/recipes/opentom/ttimgextract.bb
new file mode 100644
index 0000000000..02d2e1515d
--- /dev/null
+++ b/recipes/opentom/ttimgextract.bb
@@ -0,0 +1,17 @@
+LICENSE = "None"
+DESCRIPTION = "A tool to extract the ttsystem images into their components."
+
+SRC_URI = "svn://svn.opentom.org/opentom/trunk/;module=ttimgextract;proto=http"
+
+PV = "0.0+svn${SRCDATE}"
+S = "${WORKDIR}/${PN}"
+
+
+do_compile() {
+ ${CC} -o ttimgextract ttimgextract.c -DPATH_MAX=4096 ${TARGET_CC_ARCH}
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/ttimgextract ${D}${bindir}/
+}