aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openttd
diff options
context:
space:
mode:
authorThomas Zimmermann <ml@vdm-design.de>2009-11-27 09:40:58 +0000
committerKlaus Kurzmann <mok@fluxnetz.de>2009-11-27 11:44:46 +0100
commit6372f6f812ce52e7e5495949894b09ef80055ed6 (patch)
tree396cd6f6d2b17db64ae46a7002f7ee56aaddf36b /recipes/openttd
parent7b2a48f169ec2f0ffca1a9465364d42d5a0ddb6a (diff)
downloadopenembedded-6372f6f812ce52e7e5495949894b09ef80055ed6.tar.gz
openttd: add version 0.7.4-RC1 and sound and graphic files from openttdcoop.org
* Can't reuse .inc because openttd won't build with --target configure option * Sounds and Graphics from openttdcoop.org are GPL and CC licensed files to replace the propertarie files needed by this game Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
Diffstat (limited to 'recipes/openttd')
-rw-r--r--recipes/openttd/files/openttd.cfg4
-rw-r--r--recipes/openttd/openttd-gfx_0.1.1.bb16
-rw-r--r--recipes/openttd/openttd-sfx_0.1.0.bb16
-rw-r--r--recipes/openttd/openttd_0.7.4-RC1.bb49
4 files changed, 85 insertions, 0 deletions
diff --git a/recipes/openttd/files/openttd.cfg b/recipes/openttd/files/openttd.cfg
new file mode 100644
index 0000000000..614ce1e539
--- /dev/null
+++ b/recipes/openttd/files/openttd.cfg
@@ -0,0 +1,4 @@
+[misc]
+resolution = 480,640
+[gui]
+left_mouse_btn_scrolling = true \ No newline at end of file
diff --git a/recipes/openttd/openttd-gfx_0.1.1.bb b/recipes/openttd/openttd-gfx_0.1.1.bb
new file mode 100644
index 0000000000..f791a8835e
--- /dev/null
+++ b/recipes/openttd/openttd-gfx_0.1.1.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Grafik files for openttd"
+HOMEPAGE = "http://bundles.openttdcoop.org/opengfx/"
+LICENSE = "GPLv2"
+
+PACKAGE_ARCH = "all"
+
+SRC_URI = "http://bundles.openttdcoop.org/download.php?file=opengfx%2Freleases%2Fopengfx-${PV}.zip"
+
+do_install() {
+ mv ${WORKDIR}/docs/license.txt ${WORKDIR}/gfx_license.txt
+ install -d ${D}${datadir}/games/openttd/data/
+ install -m 0644 ${WORKDIR}/opengfx-${PV}.tar ${D}${datadir}/games/openttd/data/
+ install -m 0644 ${WORKDIR}/gfx_license.txt ${D}${datadir}/games/openttd/data/
+}
+
+FILES_${PN} = "${datadir}"
diff --git a/recipes/openttd/openttd-sfx_0.1.0.bb b/recipes/openttd/openttd-sfx_0.1.0.bb
new file mode 100644
index 0000000000..05dd021372
--- /dev/null
+++ b/recipes/openttd/openttd-sfx_0.1.0.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Sound files for openttd"
+HOMEPAGE = "http://bundles.openttdcoop.org/opensfx/"
+LICENSE = "CC Sampling Plus 1.0"
+
+PACKAGE_ARCH = "all"
+
+SRC_URI = "http://bundles.openttdcoop.org/download.php?file=opensfx%2Freleases%2Fopensfx-${PV}.zip"
+
+do_install() {
+ mv ${WORKDIR}/license.txt ${WORKDIR}/sfx_license.txt
+ install -d ${D}${datadir}/games/openttd/data/
+ install -m 0644 ${WORKDIR}/opensfx-${PV}.tar ${D}${datadir}/games/openttd/data/
+ install -m 0644 ${WORKDIR}/sfx_license.txt ${D}${datadir}/games/openttd/data/
+}
+
+FILES_${PN} = "${datadir}"
diff --git a/recipes/openttd/openttd_0.7.4-RC1.bb b/recipes/openttd/openttd_0.7.4-RC1.bb
new file mode 100644
index 0000000000..bbb570352b
--- /dev/null
+++ b/recipes/openttd/openttd_0.7.4-RC1.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "Open source clone of the Microprose game 'Transport Tycoon Deluxe' - SDL edition."
+HOMEPAGE = "http://www.openttd.org"
+LICENSE = "GPLv2"
+DEPENDS = "libsdl-net libpng zlib freetype fontconfig"
+RRECOMMENDS = "openttd-gfx openttd-sfx"
+
+inherit siteinfo sdl
+
+SRC_URI ="http://binaries.openttd.org/releases/${PV}/${P}-source.tar.bz2 "
+SRC_URI_append_shr = " file://openttd.cfg"
+
+APPIMAGE = "media/openttd.128.png"
+
+do_configure() {
+ # The way the OTTD configure system handles the application's directories
+ # isn't the way autotools does it. Mainly prefix is always prepended even if
+ # absolute binary-dir and data-dir is given.
+
+ ${S}/configure \
+ --host=${TARGET_SYS} \
+ --windres=${MACHINE_DISPLAY_WIDTH_PIXELS}x${MACHINE_DISPLAY_HEIGHT_PIXELS} \
+ --os=UNIX \
+ --endian=${SITEINFO_ENDIANESS} \
+ --prefix-dir=${prefix} \
+ --binary-dir=bin \
+ --with-midi=/bin/true \
+ --with-zlib=${STAGING_LIBDIR} \
+ --with-png \
+ --with-freetype \
+ --without-icu \
+ --without-allegro \
+ --cc-build=gcc \
+ --cc-host=${TARGET_SYS}-gcc \
+ --cxx-build=g++ \
+ --cxx-host=${TARGET_SYS}-g++ \
+ --strip=${TARGET_SYS}-strip \
+ --install-dir=${D}
+}
+
+do_install() {
+ oe_runmake install
+}
+
+do_install_append_shr() {
+ install -d ${D}${datadir}/games/openttd/
+ install -m 0644 ${WORKDIR}/openttd.cfg ${D}${datadir}/games/openttd/
+}
+
+FILES_${PN} += "${datadir}"