aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openttd
diff options
context:
space:
mode:
authorRobert Schuster <r.schuster@tarent.de>2011-03-12 17:20:12 +0100
committerRobert Schuster <r.schuster@tarent.de>2011-03-12 17:20:12 +0100
commita46f563776ddc4f34338f3b935d6815cde5f2a79 (patch)
tree6c4d4b7715c58cff12f482fafc9f794de973d192 /recipes/openttd
parentc80848bdba9d377a40608dda2988016762043ac2 (diff)
downloadopenembedded-a46f563776ddc4f34338f3b935d6815cde5f2a79.tar.gz
openttd 0.7.4: Converted to use openttd.inc
* also using proper compiler+flags now, hence increased PR Signed-off-by: Robert Schuster <r.schuster@tarent.de>
Diffstat (limited to 'recipes/openttd')
-rw-r--r--recipes/openttd/openttd.inc64
-rw-r--r--recipes/openttd/openttd_0.7.4.bb44
2 files changed, 32 insertions, 76 deletions
diff --git a/recipes/openttd/openttd.inc b/recipes/openttd/openttd.inc
index e9bb8c367e..faf702ddd6 100644
--- a/recipes/openttd/openttd.inc
+++ b/recipes/openttd/openttd.inc
@@ -1,48 +1,44 @@
-# Note: OpenTTD's build system changed considerably in 0.6.x
-# This include file is written towards the newer versions.
-
-DESCRIPTION = "Open source clone of the Microprose game 'Transport Tycoon Deluxe' - SDL edition. \
-This package provides the engine only. You will need to get the data file elsewhere \
-through official channels."
-HOMEPAGE = "http://openttd.sf.net"
+DESCRIPTION = "Open source clone of the Microprose game 'Transport Tycoon Deluxe' - SDL edition."
+HOMEPAGE = "http://www.openttd.org"
LICENSE = "GPLv2"
-
DEPENDS = "libsdl-net libpng zlib freetype fontconfig"
+RRECOMMENDS_${PN} = "openttd-gfx openttd-sfx"
-SRC_URI = "http://binaries.openttd.org/releases/${PV}/${P}-source.tar.bz2"
+SRC_URI ="http://binaries.openttd.org/releases/${PV}/${P}-source.tar.bz2"
-APPIMAGE = "media/openttd.48.png"
+APPIMAGE = "media/openttd.128.png"
inherit siteinfo sdl
do_configure() {
- # The way the OTTD configure system handles the application's directories
+ # The way the OTTD configure system handles the application's directories
# isn't the way autotools does it. Mainly prefix is always prepended even if
- # absolute binary-dir and data-dir is given. Sigh ...
-
- # Disabling MIDI feature for now.
- ./configure \
- --build=${BUILD_SYS} \
- --host=${TARGET_SYS} \
- --windres=${MACHINE_DISPLAY_WIDTH_PIXELS}x${MACHINE_DISPLAY_HEIGHT_PIXELS} \
- --os=UNIX \
- --endian=${SITEINFO_ENDIANNESS} \
- --prefix-dir=${prefix} \
- --binary-dir=bin \
- --with-midi=/bin/true \
- --with-zlib=${STAGING_LIBDIR} \
- --with-png \
- --with-freetype \
- --cc-build=gcc \
- --cc-host=${TARGET_SYS}-gcc \
- --cxx-build=g++ \
- --cxx-host=${TARGET_SYS}-g++ \
- --strip=${TARGET_SYS}-strip \
- --install-dir=${D}
+ # absolute binary-dir and data-dir is given.
+
+ ${S}/configure \
+ --host=${TARGET_SYS} \
+ --windres=${MACHINE_DISPLAY_WIDTH_PIXELS}x${MACHINE_DISPLAY_HEIGHT_PIXELS} \
+ --os=UNIX \
+ --endian=${SITEINFO_ENDIANNESS} \
+ --prefix-dir=${prefix} \
+ --binary-dir=bin \
+ --with-midi=/bin/true \
+ --with-zlib=${STAGING_LIBDIR} \
+ --with-png \
+ --with-freetype \
+ --without-icu \
+ --without-allegro \
+ --cc-build='${BUILD_CC}' \
+ --cc-host='${CC}' \
+ --cxx-build='${BUILD_CXX}' \
+ --cxx-host='${CXX}' \
+ --strip='${STRIP}' \
+ --install-dir=${D}
}
do_install() {
- oe_runmake install
+ oe_runmake install
}
-FILES_${PN} += "${datadir}/*"
+FILES_${PN} += "${datadir}"
+
diff --git a/recipes/openttd/openttd_0.7.4.bb b/recipes/openttd/openttd_0.7.4.bb
index a286135c18..d59eb6fa9c 100644
--- a/recipes/openttd/openttd_0.7.4.bb
+++ b/recipes/openttd/openttd_0.7.4.bb
@@ -1,53 +1,13 @@
-DESCRIPTION = "Open source clone of the Microprose game 'Transport Tycoon Deluxe' - SDL edition."
-HOMEPAGE = "http://www.openttd.org"
-LICENSE = "GPLv2"
-DEPENDS = "libsdl-net libpng zlib freetype fontconfig"
-RRECOMMENDS_${PN} = "openttd-gfx openttd-sfx"
-PR = "r1"
+require openttd.inc
-inherit siteinfo sdl
+PR = "r2"
-SRC_URI ="http://binaries.openttd.org/releases/${PV}/${P}-source.tar.bz2 "
SRC_URI_append_shr = " file://openttd.cfg"
-APPIMAGE = "media/openttd.128.png"
-
-do_configure() {
- # The way the OTTD configure system handles the application's directories
- # isn't the way autotools does it. Mainly prefix is always prepended even if
- # absolute binary-dir and data-dir is given.
-
- ${S}/configure \
- --host=${TARGET_SYS} \
- --windres=${MACHINE_DISPLAY_WIDTH_PIXELS}x${MACHINE_DISPLAY_HEIGHT_PIXELS} \
- --os=UNIX \
- --endian=${SITEINFO_ENDIANNESS} \
- --prefix-dir=${prefix} \
- --binary-dir=bin \
- --with-midi=/bin/true \
- --with-zlib=${STAGING_LIBDIR} \
- --with-png \
- --with-freetype \
- --without-icu \
- --without-allegro \
- --cc-build=gcc \
- --cc-host=${TARGET_SYS}-gcc \
- --cxx-build=g++ \
- --cxx-host=${TARGET_SYS}-g++ \
- --strip=${TARGET_SYS}-strip \
- --install-dir=${D}
-}
-
-do_install() {
- oe_runmake install
-}
-
do_install_append_shr() {
install -d ${D}${datadir}/games/openttd/data/
install -m 0644 ${WORKDIR}/openttd.cfg ${D}${datadir}/games/openttd/data/
}
-FILES_${PN} += "${datadir}"
-
SRC_URI[md5sum] = "30763b0dc6d77386a23261ad4b2cded8"
SRC_URI[sha256sum] = "014286af4b978fec3845fe276d40d07789acd4ac67b5f489f9bdfdf0eed6ad27"