aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opie-bluetoothmanager
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/opie-bluetoothmanager
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/opie-bluetoothmanager')
-rw-r--r--recipes/opie-bluetoothmanager/opie-bluetoothmanager.inc22
-rw-r--r--recipes/opie-bluetoothmanager/opie-bluetoothmanager_1.2.2.bb5
-rw-r--r--recipes/opie-bluetoothmanager/opie-bluetoothmanager_1.2.3.bb7
-rw-r--r--recipes/opie-bluetoothmanager/opie-bluetoothmanager_1.2.4.bb7
-rw-r--r--recipes/opie-bluetoothmanager/opie-bluetoothmanager_cvs.bb6
5 files changed, 47 insertions, 0 deletions
diff --git a/recipes/opie-bluetoothmanager/opie-bluetoothmanager.inc b/recipes/opie-bluetoothmanager/opie-bluetoothmanager.inc
new file mode 100644
index 0000000000..84d737b527
--- /dev/null
+++ b/recipes/opie-bluetoothmanager/opie-bluetoothmanager.inc
@@ -0,0 +1,22 @@
+DESCRIPTION = "Bluetooth manager for Opie"
+SECTION = "opie/settings"
+PRIORITY = "optional"
+DEPENDS = "libopietooth1 obexftp"
+RDEPENDS = "opie-bluepin"
+LICENSE = "GPL"
+APPNAME = "bluetooth-manager"
+
+S = "${WORKDIR}/manager"
+
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${STAGING_INCDIR}/opietooth"
+EXTRA_QMAKEVARS_PRE += "LIBOBEXFTP_INC_DIR=${STAGING_INCDIR}/obexftp"
+
+inherit opie
+
+# Files: plugins/application/libbluetooth-manager.so* bin/bluetooth-manager apps/Settings/bluetooth-manager.desktop pics/opietooth/* pics/opietooth/icons/*
+do_install() {
+ install -d ${D}${palmtopdir}/pics/opietooth/
+ install -d ${D}${palmtopdir}/pics/opietooth/icons/
+ install -m 0644 ${WORKDIR}/pics/opietooth/*.png ${D}${palmtopdir}/pics/opietooth/
+ install -m 0644 ${WORKDIR}/pics/opietooth/icons/*.png ${D}${palmtopdir}/pics/opietooth/icons/
+}
diff --git a/recipes/opie-bluetoothmanager/opie-bluetoothmanager_1.2.2.bb b/recipes/opie-bluetoothmanager/opie-bluetoothmanager_1.2.2.bb
new file mode 100644
index 0000000000..6a27b53101
--- /dev/null
+++ b/recipes/opie-bluetoothmanager/opie-bluetoothmanager_1.2.2.bb
@@ -0,0 +1,5 @@
+require ${PN}.inc
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/net/opietooth/manager \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/apps \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/pics"
diff --git a/recipes/opie-bluetoothmanager/opie-bluetoothmanager_1.2.3.bb b/recipes/opie-bluetoothmanager/opie-bluetoothmanager_1.2.3.bb
new file mode 100644
index 0000000000..2eb719fbfc
--- /dev/null
+++ b/recipes/opie-bluetoothmanager/opie-bluetoothmanager_1.2.3.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+PR = "r1"
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/net/opietooth/manager \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/apps \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/pics"
diff --git a/recipes/opie-bluetoothmanager/opie-bluetoothmanager_1.2.4.bb b/recipes/opie-bluetoothmanager/opie-bluetoothmanager_1.2.4.bb
new file mode 100644
index 0000000000..b688603b24
--- /dev/null
+++ b/recipes/opie-bluetoothmanager/opie-bluetoothmanager_1.2.4.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+PR = "r0"
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/net/opietooth/manager \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/apps \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/pics"
diff --git a/recipes/opie-bluetoothmanager/opie-bluetoothmanager_cvs.bb b/recipes/opie-bluetoothmanager/opie-bluetoothmanager_cvs.bb
new file mode 100644
index 0000000000..cd58cfc6c3
--- /dev/null
+++ b/recipes/opie-bluetoothmanager/opie-bluetoothmanager_cvs.bb
@@ -0,0 +1,6 @@
+require ${PN}.inc
+PV = "${OPIE_CVS_PV}"
+
+SRC_URI = "${HANDHELDS_CVS};module=opie/noncore/net/opietooth/manager \
+ ${HANDHELDS_CVS};module=opie/apps \
+ ${HANDHELDS_CVS};module=opie/pics"