summaryrefslogtreecommitdiffstats
path: root/recipes/opie-init
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman <raster@rasterman.com>2009-04-17 15:44:58 +1000
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2009-04-17 15:48:45 +1000
commit212e36417ae27e1be11147168b6f5cdfd1c5eda9 (patch)
tree00892cc3bca94534140f1e44ab98b4e58587410c /recipes/opie-init
parentd92391844e4454ba9ea3af5b4273721496511ebb (diff)
downloadopenembedded-212e36417ae27e1be11147168b6f5cdfd1c5eda9.tar.gz
angstrom, exquisite, psplash, opkg, angsrtom-images, sysvinit: abstract splash
this abstracts psplash to be generic. now as long as something provides a splashfuncs file that sysvinit (and other scripts) can source, and all the approproate init hooks to start the splash etc. you can use psplash, exquisitie, usplash or anything that tickles your fancy. this moves splash toa ${SPLASH} variable to include in your image (or override). the default in angstrom is psplash - unless you override it. opkg also runs a configure script that cna take forever - and so this speically sends off some splash commands (if there) to let you know the systme is alive and working (but just busy). this is one commit as if this breaks things you either want to fix the minor break or totally revert the whole patch. i hope it didn't break anything.
Diffstat (limited to 'recipes/opie-init')
-rwxr-xr-xrecipes/opie-init/opie-init/opie4
-rw-r--r--recipes/opie-init/opie-init_1.2.2.bb2
2 files changed, 3 insertions, 3 deletions
diff --git a/recipes/opie-init/opie-init/opie b/recipes/opie-init/opie-init/opie
index d7e06e5ce2..6bebec7955 100755
--- a/recipes/opie-init/opie-init/opie
+++ b/recipes/opie-init/opie-init/opie
@@ -43,8 +43,8 @@ fi
case $1 in
'start')
# Turn off psplash if any - sleep is required for anti-race
- if [ -e /mnt/.psplash ]; then
- TMPDIR=/mnt/.psplash psplash-write "QUIT" || true
+ if [ -e /mnt/.splash ]; then
+ TMPDIR=/mnt/.splash splash-write "QUIT" || true
sleep 1
fi
diff --git a/recipes/opie-init/opie-init_1.2.2.bb b/recipes/opie-init/opie-init_1.2.2.bb
index b52e162e50..0a03abbc56 100644
--- a/recipes/opie-init/opie-init_1.2.2.bb
+++ b/recipes/opie-init/opie-init_1.2.2.bb
@@ -1,5 +1,5 @@
require ${PN}.inc
-PR = "r8"
+PR = "r9"
SRC_URI = "file://opie-reorgfiles \
file://opie \