aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opie-parashoot
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/opie-parashoot
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/opie-parashoot')
-rw-r--r--recipes/opie-parashoot/opie-parashoot.inc18
-rw-r--r--recipes/opie-parashoot/opie-parashoot_1.2.2.bb7
-rw-r--r--recipes/opie-parashoot/opie-parashoot_1.2.3.bb6
-rw-r--r--recipes/opie-parashoot/opie-parashoot_1.2.4.bb18
-rw-r--r--recipes/opie-parashoot/opie-parashoot_cvs.bb7
5 files changed, 56 insertions, 0 deletions
diff --git a/recipes/opie-parashoot/opie-parashoot.inc b/recipes/opie-parashoot/opie-parashoot.inc
new file mode 100644
index 0000000000..ec10d07c80
--- /dev/null
+++ b/recipes/opie-parashoot/opie-parashoot.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "Game: shoot the parachutists"
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPNAME = "parashoot"
+
+
+S = "${WORKDIR}/${APPNAME}"
+
+inherit opie
+
+# FILES plugins/application/libparashoot.so* bin/parashoot apps/Games/parashoot.desktop pics/parashoot
+do_install() {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.xpm ${D}${palmtopdir}/pics/${APPNAME}/
+}
+
diff --git a/recipes/opie-parashoot/opie-parashoot_1.2.2.bb b/recipes/opie-parashoot/opie-parashoot_1.2.2.bb
new file mode 100644
index 0000000000..f7099c895c
--- /dev/null
+++ b/recipes/opie-parashoot/opie-parashoot_1.2.2.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/games/parashoot \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/pics \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/apps"
diff --git a/recipes/opie-parashoot/opie-parashoot_1.2.3.bb b/recipes/opie-parashoot/opie-parashoot_1.2.3.bb
new file mode 100644
index 0000000000..bf7f592bd8
--- /dev/null
+++ b/recipes/opie-parashoot/opie-parashoot_1.2.3.bb
@@ -0,0 +1,6 @@
+require ${PN}.inc
+
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/games/parashoot \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/pics \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/apps"
diff --git a/recipes/opie-parashoot/opie-parashoot_1.2.4.bb b/recipes/opie-parashoot/opie-parashoot_1.2.4.bb
new file mode 100644
index 0000000000..f7033f94dd
--- /dev/null
+++ b/recipes/opie-parashoot/opie-parashoot_1.2.4.bb
@@ -0,0 +1,18 @@
+require ${PN}.inc
+
+PR = "r1"
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/games/parashoot \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/pics \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/sounds \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/apps"
+
+# FILES plugins/application/libparashoot.so* bin/parashoot apps/Games/parashoot.desktop pics/parashoot sounds/parashoot
+do_install() {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.xpm ${D}${palmtopdir}/pics/${APPNAME}/
+ install -d ${D}${palmtopdir}/sounds/${APPNAME}/
+ install -m 0644 ${WORKDIR}/sounds/${APPNAME}/*.wav ${D}${palmtopdir}/sounds/${APPNAME}/
+}
+
diff --git a/recipes/opie-parashoot/opie-parashoot_cvs.bb b/recipes/opie-parashoot/opie-parashoot_cvs.bb
new file mode 100644
index 0000000000..2a29dfa2d6
--- /dev/null
+++ b/recipes/opie-parashoot/opie-parashoot_cvs.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+PV = "${OPIE_CVS_PV}"
+
+SRC_URI = "${HANDHELDS_CVS};module=opie/noncore/games/parashoot \
+ ${HANDHELDS_CVS};module=opie/pics \
+ ${HANDHELDS_CVS};module=opie/apps"