aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opie-sounds
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/opie-sounds
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/opie-sounds')
-rw-r--r--recipes/opie-sounds/opie-sounds.inc18
-rw-r--r--recipes/opie-sounds/opie-sounds_1.2.2.bb5
-rw-r--r--recipes/opie-sounds/opie-sounds_1.2.3.bb5
-rw-r--r--recipes/opie-sounds/opie-sounds_1.2.4.bb5
-rw-r--r--recipes/opie-sounds/opie-sounds_cvs.bb6
5 files changed, 39 insertions, 0 deletions
diff --git a/recipes/opie-sounds/opie-sounds.inc b/recipes/opie-sounds/opie-sounds.inc
new file mode 100644
index 0000000000..aa39e6e5d7
--- /dev/null
+++ b/recipes/opie-sounds/opie-sounds.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "Common Opie Sounds"
+SECTION = "opie/base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+S = "${WORKDIR}/sounds"
+
+SOUNDS = "alarm touchsound keysound"
+
+do_install() {
+ install -d ${D}${palmtopdir}/sounds/
+ for i in ${SOUNDS}
+ do
+ install $i.wav ${D}${palmtopdir}/sounds/$i.wav
+ done
+}
+
+FILES_${PN} = "${palmtopdir}"
diff --git a/recipes/opie-sounds/opie-sounds_1.2.2.bb b/recipes/opie-sounds/opie-sounds_1.2.2.bb
new file mode 100644
index 0000000000..9bd0cfa80f
--- /dev/null
+++ b/recipes/opie-sounds/opie-sounds_1.2.2.bb
@@ -0,0 +1,5 @@
+require ${PN}.inc
+
+TAG = "${@'v' + bb.data.getVar('PV',d,1).replace('.', '_')}"
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/sounds"
diff --git a/recipes/opie-sounds/opie-sounds_1.2.3.bb b/recipes/opie-sounds/opie-sounds_1.2.3.bb
new file mode 100644
index 0000000000..9bd0cfa80f
--- /dev/null
+++ b/recipes/opie-sounds/opie-sounds_1.2.3.bb
@@ -0,0 +1,5 @@
+require ${PN}.inc
+
+TAG = "${@'v' + bb.data.getVar('PV',d,1).replace('.', '_')}"
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/sounds"
diff --git a/recipes/opie-sounds/opie-sounds_1.2.4.bb b/recipes/opie-sounds/opie-sounds_1.2.4.bb
new file mode 100644
index 0000000000..9bd0cfa80f
--- /dev/null
+++ b/recipes/opie-sounds/opie-sounds_1.2.4.bb
@@ -0,0 +1,5 @@
+require ${PN}.inc
+
+TAG = "${@'v' + bb.data.getVar('PV',d,1).replace('.', '_')}"
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/sounds"
diff --git a/recipes/opie-sounds/opie-sounds_cvs.bb b/recipes/opie-sounds/opie-sounds_cvs.bb
new file mode 100644
index 0000000000..fc16d24601
--- /dev/null
+++ b/recipes/opie-sounds/opie-sounds_cvs.bb
@@ -0,0 +1,6 @@
+require ${PN}.inc
+
+PV = "${OPIE_CVS_PV}"
+PR = "r1"
+
+SRC_URI = "${HANDHELDS_CVS};module=opie/sounds"