aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opie-theme
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/opie-theme
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/opie-theme')
-rw-r--r--recipes/opie-theme/opie-theme.inc45
-rw-r--r--recipes/opie-theme/opie-theme_1.2.2.bb6
-rw-r--r--recipes/opie-theme/opie-theme_1.2.3.bb6
-rw-r--r--recipes/opie-theme/opie-theme_1.2.4.bb6
-rw-r--r--recipes/opie-theme/opie-theme_cvs.bb7
5 files changed, 70 insertions, 0 deletions
diff --git a/recipes/opie-theme/opie-theme.inc b/recipes/opie-theme/opie-theme.inc
new file mode 100644
index 0000000000..0017154a56
--- /dev/null
+++ b/recipes/opie-theme/opie-theme.inc
@@ -0,0 +1,45 @@
+DESCRIPTION = "Themed style"
+SECTION = "opie/styles"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPNAME = "theme"
+
+
+S = "${WORKDIR}/${APPNAME}"
+
+inherit opie
+
+# FILES plugins/styles/libtheme.so*
+do_install() {
+ install -d ${D}${palmtopdir}/plugins/styles/pixmaps/
+ install -d ${D}${palmtopdir}/plugins/styles/themes/
+ for t in cleannsimple GradE8 ixpe luna
+ do
+ install -d ${D}${palmtopdir}/plugins/styles/pixmaps/$t/
+ for f in ../styles/pixmaps/$t/*
+ do
+ [ -f $f ] && install -m 0644 $f ${D}${palmtopdir}/plugins/styles/pixmaps/$t/
+ done
+ install -m 0644 ../styles/themes/$t.themerc ${D}${palmtopdir}/plugins/styles/themes/
+ done
+ for t in lumonmarble lumonwave
+ do
+ install -d ${D}${palmtopdir}/plugins/styles/pixmaps/lumon/
+ for f in ../styles/pixmaps/lumon/*
+ do
+ [ -f $f ] && install -m 0644 $f ${D}${palmtopdir}/plugins/styles/pixmaps/lumon/
+ done
+ install -m 0644 ../styles/themes/$t.themerc ${D}${palmtopdir}/plugins/styles/themes/
+ done
+}
+
+PACKAGES += " opie-theme-cleannsimple opie-theme-grade8 opie-theme-ixpe opie-theme-lumonmarble \
+ opie-theme-lumonwave opie-theme-luna "
+
+FILES_opie-theme = " ${palmtopdir}/plugins/styles/libtheme.so*"
+FILES_opie-theme-cleannsimple = " ${palmtopdir}/plugins/styles/themes/cleannsimple.themerc ${palmtopdir}/plugins/styles/pixmaps/cleannsimple/*.png"
+FILES_opie-theme-grade8 = " ${palmtopdir}/plugins/styles/themes/GradE8.themerc ${palmtopdir}/plugins/styles/pixmaps/GradE8/*.png"
+FILES_opie-theme-ixpe = " ${palmtopdir}/plugins/styles/themes/ixpe.themerc ${palmtopdir}/plugins/styles/pixmaps/ixpe/*.png"
+FILES_opie-theme-lumonmarble = " ${palmtopdir}/plugins/styles/themes/lumonmarble.themerc ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowleft.png ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowright.png ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowup.png ${palmtopdir}/plugins/styles/pixmaps/lumon/backgroundwhitemarble.png ${palmtopdir}/plugins/styles/pixmaps/lumon/backgroundbluemarble.png ${palmtopdir}/plugins/styles/pixmaps/lumon/button.png ${palmtopdir}/plugins/styles/pixmaps/lumon/buttonborder.png ${palmtopdir}/plugins/styles/pixmaps/lumon/buttonborderdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/buttondown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/checkbox.png ${palmtopdir}/plugins/styles/pixmaps/lumon/checkboxdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/hscrollgroove.png ${palmtopdir}/plugins/styles/pixmaps/lumon/menubar.png ${palmtopdir}/plugins/styles/pixmaps/lumon/menuitemdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/radio.png ${palmtopdir}/plugins/styles/pixmaps/lumon/radiodown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/scrollbutton.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowleft.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowright.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowup.png ${palmtopdir}/plugins/styles/pixmaps/lumon/tab.png ${palmtopdir}/plugins/styles/pixmaps/lumon/tabdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/vscrollgroove.png"
+FILES_opie-theme-lumonwave = " ${palmtopdir}/plugins/styles/themes/lumonwave.themerc ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowleft.png ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowright.png ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowup.png ${palmtopdir}/plugins/styles/pixmaps/lumon/backgroundwave.png ${palmtopdir}/plugins/styles/pixmaps/lumon/backgroundwaveblue.png ${palmtopdir}/plugins/styles/pixmaps/lumon/button.png ${palmtopdir}/plugins/styles/pixmaps/lumon/buttonborder.png ${palmtopdir}/plugins/styles/pixmaps/lumon/buttonborderdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/buttondown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/checkbox.png ${palmtopdir}/plugins/styles/pixmaps/lumon/checkboxdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/hscrollgroove.png ${palmtopdir}/plugins/styles/pixmaps/lumon/menubar.png ${palmtopdir}/plugins/styles/pixmaps/lumon/menuitemdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/radio.png ${palmtopdir}/plugins/styles/pixmaps/lumon/radiodown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/scrollbutton.png ${palmtopdir}/plugins/styles/pixmaps/lumon/splitter.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowleft.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowright.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowup.png ${palmtopdir}/plugins/styles/pixmaps/lumon/tab.png ${palmtopdir}/plugins/styles/pixmaps/lumon/tabdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/vscrollgroove.png"
+FILES_opie-theme-luna = " ${palmtopdir}/plugins/styles/themes/luna.themerc ${palmtopdir}/plugins/styles/pixmaps/luna/*.png"
diff --git a/recipes/opie-theme/opie-theme_1.2.2.bb b/recipes/opie-theme/opie-theme_1.2.2.bb
new file mode 100644
index 0000000000..fc20e7fd60
--- /dev/null
+++ b/recipes/opie-theme/opie-theme_1.2.2.bb
@@ -0,0 +1,6 @@
+require ${PN}.inc
+PR = "r1"
+
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/styles/theme \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/plugins/styles "
diff --git a/recipes/opie-theme/opie-theme_1.2.3.bb b/recipes/opie-theme/opie-theme_1.2.3.bb
new file mode 100644
index 0000000000..2e3900855a
--- /dev/null
+++ b/recipes/opie-theme/opie-theme_1.2.3.bb
@@ -0,0 +1,6 @@
+require ${PN}.inc
+PR = "r0"
+
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/styles/theme \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/plugins/styles "
diff --git a/recipes/opie-theme/opie-theme_1.2.4.bb b/recipes/opie-theme/opie-theme_1.2.4.bb
new file mode 100644
index 0000000000..2e3900855a
--- /dev/null
+++ b/recipes/opie-theme/opie-theme_1.2.4.bb
@@ -0,0 +1,6 @@
+require ${PN}.inc
+PR = "r0"
+
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/styles/theme \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/plugins/styles "
diff --git a/recipes/opie-theme/opie-theme_cvs.bb b/recipes/opie-theme/opie-theme_cvs.bb
new file mode 100644
index 0000000000..5b9a33142d
--- /dev/null
+++ b/recipes/opie-theme/opie-theme_cvs.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+PR = "r1"
+
+PV = "${OPIE_CVS_PV}"
+
+SRC_URI = "${HANDHELDS_CVS};module=opie/noncore/styles/theme \
+ ${HANDHELDS_CVS};module=opie/plugins/styles "