aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opkg/files
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2009-04-29 14:25:14 +0100
committerGraeme Gregory <dp@xora.org.uk>2009-04-29 14:32:37 +0100
commitac4a2334cf292d5a131b60002753612db5c9bda2 (patch)
tree13ac161f86bbc35358ca4686fb6d356cd5281fce /recipes/opkg/files
parent565e76ba4588fc2baa34862f7378f243d117ee39 (diff)
downloadopenembedded-ac4a2334cf292d5a131b60002753612db5c9bda2.tar.gz
recipes/opkg/files/configure : fix the case where this is no splash installed.
recipes/opkg/opkg*.bb : bump PR for affected recipes
Diffstat (limited to 'recipes/opkg/files')
-rw-r--r--recipes/opkg/files/configure10
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes/opkg/files/configure b/recipes/opkg/files/configure
index 318ccb19c3..d5dd74dbf3 100644
--- a/recipes/opkg/files/configure
+++ b/recipes/opkg/files/configure
@@ -7,16 +7,18 @@ status_pulse || true
fi
# run configure in bg
-opkg-cl configure &
-PID=$!
-
-if [ -f /etc/default/splashfuncs ]; then
+if [ -f /etc/default/splashfuncs ]; then
+ opkg-cl configure &
+ PID=$!
+
# while configure still running loop
while test -d /proc/$PID; do
# tick to splash so it doesn't time out
status_tick || true
sleep 1
done
+else
+ opkg-cl configure
fi
# delete myself