aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opkg
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-11-24 10:22:43 +0100
committerKoen Kooi <koen@openembedded.org>2009-11-24 10:22:43 +0100
commit2fdf1aa1c869ea9deecee86206f49a2eca9d7c00 (patch)
tree9f74ab0bd54fc627a2ff5dedd5e6a8bfcd9083ea /recipes/opkg
parenta21551800f302fcedaf0044f9e7bf475846af11f (diff)
downloadopenembedded-2fdf1aa1c869ea9deecee86206f49a2eca9d7c00.tar.gz
opkg-target,sdk: bump SRCREV
* -native is left alone because packaged-staging needs more testing * tested install and upgrade on angstrom/beagleboard * tweaked opkg-nogpg-nocurl recipe to keep it building
Diffstat (limited to 'recipes/opkg')
-rw-r--r--recipes/opkg/opkg-nogpg-nocurl_svn.bb15
-rw-r--r--recipes/opkg/opkg-nogpg_svn.bb11
-rw-r--r--recipes/opkg/opkg.inc4
3 files changed, 13 insertions, 17 deletions
diff --git a/recipes/opkg/opkg-nogpg-nocurl_svn.bb b/recipes/opkg/opkg-nogpg-nocurl_svn.bb
index 5e1caa90d9..cd8751ae87 100644
--- a/recipes/opkg/opkg-nogpg-nocurl_svn.bb
+++ b/recipes/opkg/opkg-nogpg-nocurl_svn.bb
@@ -1,24 +1,13 @@
-require opkg_svn.bb
+require opkg-nogpg_svn.bb
DEPENDS = ""
PROVIDES += "opkg"
-SRC_URI += " \
- file://opkg_wget.patch;patch=1;maxrev=180 \
- file://reduce-nogpg-noise.patch;patch=1;maxrev=180 \
- file://opkg_wget_nogpg_01_use_vfork_gunzip.patch;patch=1 \
- file://opkg_wget_nogpg_02_use_vfork_system.patch;patch=1 \
- file://opkg_wget_nogpg_03_fix_tmpdirs.patch;patch=1 \
- file://opkg_wget_nogpg_04_default_tmpdir.patch;patch=1 \
- "
PR = "${INC_PR}"
SRCREV = "${SRCREV_pn-opkg}"
-EXTRA_OECONF += "--disable-gpg --enable-static --disable-shared"
-
-# NOTE: Use this one after svn rev 180 (should be a different recipe)
-#EXTRA_OECONF += "--disable-gpg --disable-curl --enable-static --disable-shared"
+EXTRA_OECONF += " --disable-curl --enable-static --disable-shared"
# The nogpg version isn't getting much love and has an unused variable which trips up -Werror
do_configure_prepend() {
diff --git a/recipes/opkg/opkg-nogpg_svn.bb b/recipes/opkg/opkg-nogpg_svn.bb
index a0f9614a37..9ddc589b49 100644
--- a/recipes/opkg/opkg-nogpg_svn.bb
+++ b/recipes/opkg/opkg-nogpg_svn.bb
@@ -3,11 +3,18 @@ require opkg_svn.bb
DEPENDS = "curl"
PROVIDES += "opkg"
-PR = "${INC_PR}"
+PR = "${INC_PR}.1"
SRCREV = "${SRCREV_pn-opkg}"
-EXTRA_OECONF += "--disable-gpg"
+EXTRA_OECONF += " --disable-gpg \
+ --disable-openssl \
+ --disable-ssl-curl \
+ --enable-gpg=no \
+ --enable-ssl-curl=no \
+ --enable-openssl=no"
+
+LDFLAGS_append = " -Wl,--as-needed"
# The nogpg version isn't getting much love and has an unused variable which trips up -Werror
do_configure_prepend() {
diff --git a/recipes/opkg/opkg.inc b/recipes/opkg/opkg.inc
index d744e72223..2e7baee496 100644
--- a/recipes/opkg/opkg.inc
+++ b/recipes/opkg/opkg.inc
@@ -10,8 +10,8 @@ FILESPATHPKG =. "opkg:"
SRC_URI = "svn://opkg.googlecode.com/svn;module=trunk;proto=http \
file://opkg_unarchive.patch;patch=1;maxrev=201 \
- file://opkg-intercept-cleanup.patch;patch=1 \
- file://isatty.patch;patch=1"
+ file://opkg-intercept-cleanup.patch;patch=1;maxrev=241 \
+"
SRC_URI += "file://configure"