aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/oprofile
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-01-06 13:25:31 +0800
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-01-06 06:56:04 +0100
commit3eae83257fdf3ddd15bcc4385fcd0edf543c17c7 (patch)
tree8fcea1613514c1ae38b04961fab17385b6f31ee5 /recipes/oprofile
parent0ad961a218e3a0c3c1271820a0c7d7c11f62bbc1 (diff)
downloadopenembedded-3eae83257fdf3ddd15bcc4385fcd0edf543c17c7.tar.gz
oprofile_0.9.5: Fix opcontrol in timer mode
Diffstat (limited to 'recipes/oprofile')
-rw-r--r--recipes/oprofile/oprofile/fix-timer-mode.patch32
-rw-r--r--recipes/oprofile/oprofile_0.9.5.bb4
2 files changed, 35 insertions, 1 deletions
diff --git a/recipes/oprofile/oprofile/fix-timer-mode.patch b/recipes/oprofile/oprofile/fix-timer-mode.patch
new file mode 100644
index 0000000000..bb52a3c732
--- /dev/null
+++ b/recipes/oprofile/oprofile/fix-timer-mode.patch
@@ -0,0 +1,32 @@
+Fix opcontrol in timer mode...
+
+http://oprofile.cvs.sourceforge.net/viewvc/oprofile/oprofile/utils/opcontrol?r1=1.164&r2=1.165&view=patch
+
+Index: oprofile-0.9.5/utils/opcontrol
+===================================================================
+--- oprofile-0.9.5.orig/utils/opcontrol 2010-01-06 13:22:57.703663191 +0800
++++ oprofile-0.9.5/utils/opcontrol 2010-01-06 13:23:18.113667904 +0800
+@@ -586,7 +587,7 @@
+ # setup any needed default value in chosen events
+ normalise_events()
+ {
+- if test "$NR_CHOSEN" -le 0; then
++ if test "$NR_CHOSEN" -le 0 || test "$IS_TIMER" = 1; then
+ return
+ fi
+
+@@ -1449,8 +1450,12 @@
+ --separate-thread=$SEPARATE_THREAD \
+ --separate-cpu=$SEPARATE_CPU"
+
+- if ! test -z "$OPROFILED_EVENTS"; then
+- OPD_ARGS="$OPD_ARGS --events=$OPROFILED_EVENTS"
++ if test "$IS_TIMER" = 1; then
++ OPD_ARGS="$OPD_ARGS --events="
++ else
++ if ! test -z "$OPROFILED_EVENTS"; then
++ OPD_ARGS="$OPD_ARGS --events=$OPROFILED_EVENTS"
++ fi
+ fi
+
+ if test "$VMLINUX" = "none"; then
diff --git a/recipes/oprofile/oprofile_0.9.5.bb b/recipes/oprofile/oprofile_0.9.5.bb
index 066eb050b2..2a47017142 100644
--- a/recipes/oprofile/oprofile_0.9.5.bb
+++ b/recipes/oprofile/oprofile_0.9.5.bb
@@ -1,4 +1,6 @@
require oprofile.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
+
+SRC_URI += "file://fix-timer-mode.patch;patch=1"