aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/orc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-03-15 10:15:07 +0100
committerKoen Kooi <koen@openembedded.org>2010-03-15 10:15:07 +0100
commitda0036099b326b09b3dc8b845a2ddbe8936009e4 (patch)
treeadcd9852edab296e0c5dc075ffcc54cdc3fe4e28 /recipes/orc
parentb2e3219cb67b5601675bca4beea8aa45ed2dff25 (diff)
downloadopenembedded-da0036099b326b09b3dc8b845a2ddbe8936009e4.tar.gz
orc: fix packaging, recipe style issues and factor into .inc
Diffstat (limited to 'recipes/orc')
-rw-r--r--recipes/orc/orc.inc18
-rw-r--r--recipes/orc/orc_0.4.3.bb17
2 files changed, 23 insertions, 12 deletions
diff --git a/recipes/orc/orc.inc b/recipes/orc/orc.inc
new file mode 100644
index 0000000000..7d48806c0e
--- /dev/null
+++ b/recipes/orc/orc.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "orc - The Oil Runtime Compiler"
+HOMEPAGE = "http://code.entropywave.com/projects/orc/"
+
+SRC_URI = "http://code.entropywave.com/download/orc/orc-${PV}.tar.gz;name=orc"
+
+inherit autotools pkgconfig
+
+BBCLASSEXTEND = "native"
+
+PACKAGES =+ "orc-examples"
+FILES_orc-examples = "${libdir}/orc/*"
+FILES_${PN} = "${bindir}/*"
+
+python populate_packages_prepend () {
+ libdir = bb.data.expand('${libdir}', d)
+ do_split_packages(d, libdir, '^lib(.*)\.so\.*', 'lib%s', 'ORC %s library', extra_depends='', allow_links=True)
+}
+
diff --git a/recipes/orc/orc_0.4.3.bb b/recipes/orc/orc_0.4.3.bb
index be322b79ed..6da5789e5e 100644
--- a/recipes/orc/orc_0.4.3.bb
+++ b/recipes/orc/orc_0.4.3.bb
@@ -1,18 +1,11 @@
-DESCRIPTION = "orc - The Oil Runtime Compiler"
-HOMEPAGE = "http://code.entropywave.com/projects/orc/"
-PR = "r0"
+require orc.inc
-SRC_URI = "http://code.entropywave.com/download/orc/orc-0.4.3.tar.gz;name=orc043targz"
-SRC_URI[orc043targz.md5sum] = "9b2e7030c8df8a0d371115869fe5685a"
-SRC_URI[orc043targz.sha256sum] = "4c0266d81da67fef0b2abd5e624a9ab0db5de04eb23c3ab24e22f5f9ceeefbfe"
+PR = "r1"
+
+SRC_URI[orc.md5sum] = "9b2e7030c8df8a0d371115869fe5685a"
+SRC_URI[orc.sha256sum] = "4c0266d81da67fef0b2abd5e624a9ab0db5de04eb23c3ab24e22f5f9ceeefbfe"
SRC_URI += "file://03_orcutils.patch;patch=1 \
file://99_autoreconf.patch;patch=1"
-inherit autotools pkgconfig
-
-BBCLASSEXTEND = "native"
-
-PACKAGES += "liborc"
-PACKAGES_liborc = ${libdir}