aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/otpcalc
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/otpcalc
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/otpcalc')
-rw-r--r--recipes/otpcalc/otpcalc-0.97/otpcalc-0.97-badindex.diff15
-rw-r--r--recipes/otpcalc/otpcalc-0.97/otpcalc-0.97-gtk2-gentoo.patch74
-rw-r--r--recipes/otpcalc/otpcalc-0.97/otpcalc-crypto-proto.diff16
-rw-r--r--recipes/otpcalc/otpcalc-0.97/otpcalc-man-table-format.diff37
-rw-r--r--recipes/otpcalc/otpcalc_0.97.bb26
5 files changed, 168 insertions, 0 deletions
diff --git a/recipes/otpcalc/otpcalc-0.97/otpcalc-0.97-badindex.diff b/recipes/otpcalc/otpcalc-0.97/otpcalc-0.97-badindex.diff
new file mode 100644
index 0000000000..92ccf0f03a
--- /dev/null
+++ b/recipes/otpcalc/otpcalc-0.97/otpcalc-0.97-badindex.diff
@@ -0,0 +1,15 @@
+upstream: all patches sent upstream to Anthony D. Urso <anthonyu@killa.net> by Yuri Bushmelev.
+status: pending
+origin: http://packages.gentoo.org/package/sys-auth/otpcalc?full_cat
+
+--- otpCalc-0.97.orig/callbacks.c 2004-11-24 05:57:45.000000000 +0000
++++ otpCalc-0.97/callbacks.c 2006-02-24 22:36:56.602831704 +0000
+@@ -81,7 +81,7 @@
+ void calculate(void)
+ {
+
+- void (*hashes[4])();
++ void (*hashes[5])();
+
+ gchar *challenge, *passwd, *message, *response;
+ struct tokens *set;
diff --git a/recipes/otpcalc/otpcalc-0.97/otpcalc-0.97-gtk2-gentoo.patch b/recipes/otpcalc/otpcalc-0.97/otpcalc-0.97-gtk2-gentoo.patch
new file mode 100644
index 0000000000..4157374cd3
--- /dev/null
+++ b/recipes/otpcalc/otpcalc-0.97/otpcalc-0.97-gtk2-gentoo.patch
@@ -0,0 +1,74 @@
+upstream: all patches sent upstream to Anthony D. Urso <anthonyu@killa.net> by Yuri Bushmelev.
+status: pending
+origin: http://packages.gentoo.org/package/sys-auth/otpcalc?full_cat
+
+--- otpCalc-0.97-orig/Makefile.in 2004-11-24 07:44:12.000000000 +0100
++++ otpCalc-0.97/Makefile.in 2007-12-26 00:38:52.000000000 +0100
+@@ -3,8 +3,8 @@
+
+ CC = @CC@
+ DEFS = -DVERSION=\"$(VER)\" @DEFS@
+-CFLAGS = -s -O3 -Wall -pipe `gtk-config --cflags`
+-LIBS = `gtk-config --libs` @LIBS@
++CFLAGS += -Wall -pipe `pkg-config --cflags gtk+-2.0`
++LIBS = `pkg-config --libs gtk+-2.0` @LIBS@
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+--- otpCalc-0.97-orig/callbacks.c 2004-11-24 06:57:45.000000000 +0100
++++ otpCalc-0.97/callbacks.c 2007-12-26 00:38:52.000000000 +0100
+@@ -236,7 +236,7 @@
+ }
+
+
+-void focus(GtkWidget *widget, gpointer data)
++gboolean focus(GtkWidget *widget, GdkEvent *event, gpointer data)
+ {
+
+ static GdkAtom targets;
+@@ -244,12 +244,12 @@
+
+
+ if (!autopaste)
+- return;
++ return FALSE;
+
+ targets = gdk_atom_intern("STRING", FALSE);
+
+ gtk_selection_convert(widget, GDK_SELECTION_PRIMARY, targets,
+ GDK_CURRENT_TIME);
+
+-
++ return FALSE;
+ }
+--- otpCalc-0.97-orig/gui.c 2004-11-24 07:46:53.000000000 +0100
++++ otpCalc-0.97/gui.c 2007-12-26 00:38:52.000000000 +0100
+@@ -29,7 +29,7 @@
+ GtkWidget *te_response;
+
+ unsigned short hash;
+-unsigned short newline = 1;
++unsigned short newline = 0;
+ unsigned short autopaste = 1;
+
+ int main(int argc, char *argv[])
+@@ -147,7 +147,7 @@
+
+ /* Setup the menu bar... */
+ mb_top = gtk_menu_bar_new();
+- gtk_menu_bar_set_shadow_type(GTK_MENU_BAR(mb_top), GTK_SHADOW_NONE);
++ /*gtk_menu_bar_set_shadow_type(GTK_MENU_BAR(mb_top), GTK_SHADOW_NONE);*/
+ gtk_table_attach(GTK_TABLE(ta_top), mb_top, 0, 3, 0, 1,
+ (GtkAttachOptions)(GTK_FILL),
+ (GtkAttachOptions)(0), 0, 0);
+--- otpCalc-0.97-orig/utility.c 2004-11-24 06:59:09.000000000 +0100
++++ otpCalc-0.97/utility.c 2007-12-26 00:38:52.000000000 +0100
+@@ -422,7 +422,7 @@
+ words[extract(message, 33, 11)],
+ words[extract(message, 44, 11)],
+ words[extract(message, 55, 11)],
+- (newline == 1) ? "\n" : NULL);
++ (newline == 1) ? "\n" : "");
+
+ return response;
+
diff --git a/recipes/otpcalc/otpcalc-0.97/otpcalc-crypto-proto.diff b/recipes/otpcalc/otpcalc-0.97/otpcalc-crypto-proto.diff
new file mode 100644
index 0000000000..ff51173255
--- /dev/null
+++ b/recipes/otpcalc/otpcalc-0.97/otpcalc-crypto-proto.diff
@@ -0,0 +1,16 @@
+upstream: all patches sent upstream to Anthony D. Urso <anthonyu@killa.net> by Yuri Bushmelev.
+status: pending
+origin: http://packages.gentoo.org/package/sys-auth/otpcalc?full_cat
+
+diff -urN otpCalc-0.97.orig/crypto.h otpCalc-0.97/crypto.h
+--- otpCalc-0.97.orig/crypto.h 2001-05-12 02:04:54.000000000 -0400
++++ otpCalc-0.97/crypto.h 2006-03-21 17:24:54.000000000 -0500
+@@ -1,4 +1,4 @@
+-void md4lite(char *, size_t);
+-void md5lite(char *, size_t);
+-void rmd160lite(char *, size_t);
+-void sha1lite(char *, size_t);
++void md4lite(char *message, unsigned int len);
++void md5lite(char *message, unsigned int len);
++void rmd160lite(char *message, unsigned int len);
++void sha1lite(char *message, unsigned int len);
diff --git a/recipes/otpcalc/otpcalc-0.97/otpcalc-man-table-format.diff b/recipes/otpcalc/otpcalc-0.97/otpcalc-man-table-format.diff
new file mode 100644
index 0000000000..bbe6e19e61
--- /dev/null
+++ b/recipes/otpcalc/otpcalc-0.97/otpcalc-man-table-format.diff
@@ -0,0 +1,37 @@
+upstream: all patches sent upstream to Anthony D. Urso <anthonyu@killa.net> by Yuri Bushmelev.
+status: pending
+origin: http://packages.gentoo.org/package/sys-auth/otpcalc?full_cat
+
+--- otpCalc-0.97.orig/otpCalc.man 2005-04-29 23:17:06.000000000 +0100
++++ otpCalc-0.97/otpCalc.man 2005-04-29 23:19:03.000000000 +0100
+@@ -24,18 +24,20 @@
+ the Challenge input:
+ .IP
+ .TS
+-s/key MD4
+-.br
+-otp-md4 MD4
+-.br
+-otp-md5 MD5
+-.br
+-otp-rmd160 RIPEMD-160
+-.br
+-otp-sha1 SHA1
+-.br
++allbox tab(#);
++cb l
++cb l
++cb l
++cb l
++cb l.
++s/key#MD4
++otp-md4#MD4
++otp-md5#MD5
++otp-rmd160#RIPEMD-160
++otp-sha1#SHA1
+ .TE
+ .LP
++.LP
+ In the absence of a prefix, the default hash, specified in the Settings menu,
+ is used.
+ .SH "SEE ALSO"
diff --git a/recipes/otpcalc/otpcalc_0.97.bb b/recipes/otpcalc/otpcalc_0.97.bb
new file mode 100644
index 0000000000..baeddd91a9
--- /dev/null
+++ b/recipes/otpcalc/otpcalc_0.97.bb
@@ -0,0 +1,26 @@
+HOMEPAGE = "http://killa.net/infosec/otpCalc/"
+DESCRIPTION = "An OTP and S/Key calculator for X"
+SECTION = "x11"
+LICENSE = "GPL"
+DEPENDS = "gtk+ openssl"
+PR = "r1"
+
+S = "${WORKDIR}/otpCalc-${PV}"
+
+SRC_URI = "http://killa.net/infosec/otpCalc/otpCalc-${PV}.tar.gz \
+ file://otpcalc-man-table-format.diff;patch=1 \
+ file://otpcalc-0.97-badindex.diff;patch=1 \
+ file://otpcalc-crypto-proto.diff;patch=1 \
+ file://otpcalc-0.97-gtk2-gentoo.patch;patch=1 \
+ "
+
+inherit autotools pkgconfig
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man1
+ cat ${S}/otpCalc.man | sed -e "s/VERSION/${PV}/g" | gzip -c9 > ${D}${mandir}/man1/otpCalc.1.gz
+ install -m 755 otpCalc ${D}${bindir}
+}
+
+