aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/otpkeygen
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/otpkeygen
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/otpkeygen')
-rw-r--r--recipes/otpkeygen/otpkeygen_1.3.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/otpkeygen/otpkeygen_1.3.0.bb b/recipes/otpkeygen/otpkeygen_1.3.0.bb
new file mode 100644
index 0000000000..44a4789f98
--- /dev/null
+++ b/recipes/otpkeygen/otpkeygen_1.3.0.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "OTP S/Key password generator"
+SECTION = "opie/applications"
+HOMEPAGE = "http://www.bitrot.de/pda_otpkeygen.html"
+AUTHOR = "Thomas Driemeyer <thomas@bitrot.de>"
+LICENSE = "GPL"
+APPTYPE="binary"
+PR = "r3"
+
+SRC_URI = "ftp://ftp.bitrot.de/pub/otpkeygen/otpkeygen-src_${PV}.tar.gz"
+
+S = "${WORKDIR}/src/"
+
+inherit palmtop
+
+do_configure_prepend() {
+ cd ${S} && qmake -project
+}
+
+do_install() {
+
+ install -d ${D}${palmtopdir}/apps/Applications
+ install -d ${D}${palmtopdir}/bin/
+ install -d ${D}${palmtopdir}/pics/
+
+ install -m 0755 ${WORKDIR}/src/src ${D}${palmtopdir}/bin/otpkeygen
+ install -m 0644 ${WORKDIR}/apps/Applications/otpkeygen.desktop ${D}${palmtopdir}/apps/Applications/
+ install -m 0644 ${WORKDIR}/pics/otpkeygen.png ${D}${palmtopdir}/pics/
+}