aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pad
diff options
context:
space:
mode:
authorFahad Usman <fahad_usman@mentor.com>2010-09-02 00:53:00 +0000
committerTom Rini <tom_rini@mentor.com>2010-09-30 14:03:09 -0700
commit771a89b33df37a3bee3708f21e8146cbbc88b829 (patch)
treecf38169a5d97acbad07526ad73ea70354082099d /recipes/pad
parentfd4d29eed11bf37484510e54a2fb47c913465718 (diff)
downloadopenembedded-771a89b33df37a3bee3708f21e8146cbbc88b829.tar.gz
pad-native: converted to new style staging
* Converted do_stage to do_install. * Added INC_PR = "r1" * Added NATIVE_INSTALL_WORKS = "1" Signed-off-by: Fahad Usman <fahad_usman@mentor.com> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/pad')
-rw-r--r--recipes/pad/pad-native.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes/pad/pad-native.bb b/recipes/pad/pad-native.bb
index e8c2b6d579..cc1f7aa405 100644
--- a/recipes/pad/pad-native.bb
+++ b/recipes/pad/pad-native.bb
@@ -3,6 +3,7 @@ DESCRIPTION = "Console utility for padding a file (filling with 0 to reach a spe
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/pad"
SRC_URI = "file://pad.c"
LICENSE = "PD"
+PR = "r1"
inherit native
do_compile() {
@@ -10,6 +11,9 @@ do_compile() {
${CC} -I. -o pad pad.c
}
-do_stage() {
- install -m 0755 pad ${STAGING_BINDIR}/
+do_install() {
+ install -d ${D}${bindir}/
+ install -m 0755 pad ${D}${bindir}/
}
+
+NATIVE_INSTALL_WORKS = "1"