aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/palmpre
diff options
context:
space:
mode:
authorSimon Busch <morphis@gravedo.de>2010-09-29 07:04:44 +0200
committerSimon Busch <morphis@gravedo.de>2010-10-20 09:49:29 +0200
commit5a02f6b280f7a9e9d58335d9ac72ec6b65493328 (patch)
tree219940a9bfdb1c2aa9f189740ea48943be1692fa /recipes/palmpre
parentce435227ea7a8f5d0e1d188e9b8ab9fdcb7d6c5f (diff)
downloadopenembedded-5a02f6b280f7a9e9d58335d9ac72ec6b65493328.tar.gz
palmpre-audio-scripts: add initial version
For the palmpre machine some special audio scripts are needed to do audio routing, as it is not possible to do audio routing with common tools used on other machines. Signed-off-by: Simon Busch <morphis@gravedo.de>
Diffstat (limited to 'recipes/palmpre')
-rw-r--r--recipes/palmpre/palmpre-audio-scripts_1.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/palmpre/palmpre-audio-scripts_1.0.bb b/recipes/palmpre/palmpre-audio-scripts_1.0.bb
new file mode 100644
index 0000000000..48332e73af
--- /dev/null
+++ b/recipes/palmpre/palmpre-audio-scripts_1.0.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Audio scripts necessary for audio routing on the palmpre machine"
+HOMEPAGE = "http://www.palm.com/"
+AUTHOR = "Palm Inc."
+SECTION = "console/utils"
+LICENSE = "Palm"
+
+PR = "r0"
+SRC_URI = "http://downloads.freesmartphone.org/palmpre-audio-scripts_${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "3e263163203ce66ae5f3a75776971d73"
+SRC_URI[sha256sum] = "044bbd9879f6e46b21c675421501f8920a4cab3ed4623259e2a52abecccd114e"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_install() {
+ install -d ${D}${sysconfdir}/audio/scripts
+
+ for script in `ls ${WORKDIR}/*.txt`
+ do
+ install -m 0644 "${script}" "${D}${sysconfdir}/audio/scripts"
+ done
+}
+