summaryrefslogtreecommitdiffstats
path: root/recipes/palmpre
diff options
context:
space:
mode:
authorSimon Busch <morphis@amethyst.openembedded.net>2010-12-16 20:44:37 +0100
committerSimon Busch <morphis@gravedo.de>2011-01-04 11:41:43 +0100
commit9f26a9ce94a04c97a13e0ab5d3e7227cdced30c6 (patch)
tree5abea75a4aeba68ed7ac015dcff60689330f7518 /recipes/palmpre
parent6edcf5e0f0a504262e7a47b491187bda71212896 (diff)
downloadopenembedded-9f26a9ce94a04c97a13e0ab5d3e7227cdced30c6.tar.gz
tsmd: remove initscript and bump PR
The initscript for tsmd is not needed anymore as it is started by a plugin of FSO's fsodeviced daemon. Signed-off-by: Simon Busch <morphis@amethyst.openembedded.net>
Diffstat (limited to 'recipes/palmpre')
-rwxr-xr-xrecipes/palmpre/tsmd/tsmd38
-rw-r--r--recipes/palmpre/tsmd_git.bb13
2 files changed, 2 insertions, 49 deletions
diff --git a/recipes/palmpre/tsmd/tsmd b/recipes/palmpre/tsmd/tsmd
deleted file mode 100755
index 53d94c85a7..0000000000
--- a/recipes/palmpre/tsmd/tsmd
+++ /dev/null
@@ -1,38 +0,0 @@
-#! /bin/sh
-#
-# tsmd -- This shell script starts and stops the tsmd daemon
-#
-# chkconfig: 345 10 10
-# description: a simple utility daemon which forwards all events from a independent device node to a more general uinput one
-# processname: tsmd
-
-PATH=/bin:/usr/bin:/sbin:/usr/sbin
-NAME=tsmd
-
-case "$1" in
- start)
- echo -n "Starting tsmd: "
- start-stop-daemon --start --pidfile /var/run/${NAME}.pid --make-pidfile --background -x /usr/bin/${NAME} -- -n /dev/touchscreen -f
- if [ $? = 0 ]; then
- echo "(ok)"
- else
- echo "(failed)"
- fi
- ;;
- stop)
- echo -n "Stopping tsmd: "
- start-stop-daemon --stop --pidfile /var/run/${NAME}.pid --oknodo
- rm -f /var/run/${NAME}.pid
- echo "(done)"
- ;;
- restart|force-reload)
- $0 stop
- $0 start
- ;;
- *)
- echo "Usage: /etc/init.d/tsmd {start|stop|restart|force-reload}"
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/recipes/palmpre/tsmd_git.bb b/recipes/palmpre/tsmd_git.bb
index 839e17684c..4dcdb8712d 100644
--- a/recipes/palmpre/tsmd_git.bb
+++ b/recipes/palmpre/tsmd_git.bb
@@ -6,25 +6,16 @@ LICENSE = "GPL"
DEPENDS = "tslib"
-PR = "r0"
+PR = "r1"
PV = "1.0.0+gitr${SRCPV}"
SRCREV = "798c26a7022decaebdaa829ec30852fdcf08f061"
SRC_URI = " \
${FREESMARTPHONE_GIT}/utilities.git;protocol=git;branch=master \
- file://tsmd \
"
S = "${WORKDIR}/git/palmpre/tsmd"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-inherit autotools update-rc.d
-
-INITSCRIPT_NAME = "tsmd"
-INITSCRIPT_PARAMS = "defaults 00"
-
-do_install_append() {
- install -d 0644 ${D}${sysconfdir}/init.d/
- install -m 0755 ${WORKDIR}/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/
-}
+inherit autotools