aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pam/libpam_1.0.2.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-10-20 21:37:20 +0200
committerKoen Kooi <koen@openembedded.org>2009-10-21 15:27:28 +0200
commitd81d0ec74ee6706656b3e5b3c4de36491496160a (patch)
treed9ee0c575e386b3b553cf9ae12d6d4803b8b98dc /recipes/pam/libpam_1.0.2.bb
parent926ae171023992b332300f6b80bb4098bf9f6234 (diff)
downloadopenembedded-d81d0ec74ee6706656b3e5b3c4de36491496160a.tar.gz
libpam: add meta package for all plugins
Diffstat (limited to 'recipes/pam/libpam_1.0.2.bb')
-rw-r--r--recipes/pam/libpam_1.0.2.bb26
1 files changed, 20 insertions, 6 deletions
diff --git a/recipes/pam/libpam_1.0.2.bb b/recipes/pam/libpam_1.0.2.bb
index 17d8f3028f..0151a4691d 100644
--- a/recipes/pam/libpam_1.0.2.bb
+++ b/recipes/pam/libpam_1.0.2.bb
@@ -12,7 +12,7 @@ LICENSE = "GPLv2"
DEPENDS = "flex flex-native"
-PR = "r3"
+PR = "r4"
# The project is actually called Linux-PAM but that gives
# a bad OE package name because of the upper case characters
@@ -23,9 +23,7 @@ S = "${WORKDIR}/${p}"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/libs/pam/library/${p}.tar.bz2 \
file://pam-nodocs.patch;patch=1 "
-SRC_URI_append_linux-uclibc = "file://pam-disable-nis-on-uclibc.patch;patch=1"
-SRC_URI_append_linux-uclibceabi = "file://pam-disable-nis-on-uclibc.patch;patch=1"
-SRC_URI_append_linux-uclibcspe = "file://pam-disable-nis-on-uclibc.patch;patch=1"
+SRC_URI_append_libc-uclibc = "file://pam-disable-nis-on-uclibc.patch;patch=1"
inherit autotools
@@ -34,11 +32,12 @@ LEAD_SONAME = "libpam.so.*"
# maintain the pam default layout
EXTRA_OECONF += " --includedir=${includedir}/security"
-PACKAGES_DYNAMIC += " pam-plugin-*"
+PACKAGES_DYNAMIC += " libpam-meta pam-plugin-*"
+
python populate_packages_prepend () {
import os.path
- pam_libdir = bb.data.expand('${libdir}/security', d)
+ pam_libdir = bb.data.expand('${libdir}/security', d)
pam_libdirdebug = bb.data.expand('${libdir}/security/.debug', d)
pam_filterdir = bb.data.expand('${libdir}/security/pam_filter', d)
do_split_packages(d, pam_libdir, '^pam(.*)\.so$', 'pam-plugin%s', 'PAM plugin for %s', extra_depends='')
@@ -46,6 +45,21 @@ python populate_packages_prepend () {
if os.path.exists(pam_libdirdebug):
do_split_packages(d, pam_libdirdebug, '^pam(.*)\.so$', 'pam-plugin%s-dbg', 'PAM plugin for %s debugging symbols', extra_depends='')
do_split_packages(d, pam_filterdir, '^(.*)$', 'pam-filter-%s', 'PAM filter for %s', extra_depends='')
+
+ pn = bb.data.getVar('PN', d, 1)
+ metapkg = pn + '-meta'
+ bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d)
+ bb.data.setVar('FILES_' + metapkg, "", d)
+ blacklist = [ pn + '-locale', pn + '-dev', pn + '-dbg', pn + '-doc' ]
+ metapkg_rdepends = []
+ packages = bb.data.getVar('PACKAGES', d, 1).split()
+ for pkg in packages[1:]:
+ if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.endswith('-dev') and not pkg.count('locale') and pkg.count('plugin'):
+ metapkg_rdepends.append(pkg)
+ bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d)
+ bb.data.setVar('DESCRIPTION_' + metapkg, pn + ' meta package', d)
+ packages.append(metapkg)
+ bb.data.setVar('PACKAGES', ' '.join(packages), d)
}