aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pango/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/pango/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/pango/files')
-rw-r--r--recipes/pango/files/gtk-doc.patch59
-rw-r--r--recipes/pango/files/no-tests.patch15
-rw-r--r--recipes/pango/files/pkgconfig_fixes.patch79
3 files changed, 153 insertions, 0 deletions
diff --git a/recipes/pango/files/gtk-doc.patch b/recipes/pango/files/gtk-doc.patch
new file mode 100644
index 0000000000..bee5fe6310
--- /dev/null
+++ b/recipes/pango/files/gtk-doc.patch
@@ -0,0 +1,59 @@
+--- pango/acinclude.m4.old 2004-05-08 11:31:48.000000000 +0100
++++ pango/acinclude.m4 2004-05-08 11:31:58.000000000 +0100
+@@ -55,3 +55,56 @@
+ ])
+
+
++dnl -*- mode: autoconf -*-
++
++# serial 1
++
++dnl Usage:
++dnl GTK_DOC_CHECK([minimum-gtk-doc-version])
++AC_DEFUN([GTK_DOC_CHECK],
++[
++ AC_BEFORE([AC_PROG_LIBTOOL],[$0])dnl setup libtool first
++ AC_BEFORE([AM_PROG_LIBTOOL],[$0])dnl setup libtool first
++ dnl for overriding the documentation installation directory
++ AC_ARG_WITH(html-dir,
++ AC_HELP_STRING([--with-html-dir=PATH], [path to installed docs]),,
++ [with_html_dir='${datadir}/gtk-doc/html'])
++ HTML_DIR="$with_html_dir"
++ AC_SUBST(HTML_DIR)
++
++ dnl enable/disable documentation building
++ AC_ARG_ENABLE(gtk-doc,
++ AC_HELP_STRING([--enable-gtk-doc],
++ [use gtk-doc to build documentation [default=no]]),,
++ enable_gtk_doc=no)
++
++ have_gtk_doc=no
++ if test -z "$PKG_CONFIG"; then
++ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
++ fi
++ if test "$PKG_CONFIG" != "no" && $PKG_CONFIG --exists gtk-doc; then
++ have_gtk_doc=yes
++ fi
++
++ dnl do we want to do a version check?
++ifelse([$1],[],,
++ [gtk_doc_min_version=$1
++ if test "$have_gtk_doc" = yes; then
++ AC_MSG_CHECKING([gtk-doc version >= $gtk_doc_min_version])
++ if $PKG_CONFIG --atleast-version $gtk_doc_min_version gtk-doc; then
++ AC_MSG_RESULT(yes)
++ else
++ AC_MSG_RESULT(no)
++ have_gtk_doc=no
++ fi
++ fi
++])
++ if test x$enable_gtk_doc = xyes; then
++ if test "$have_gtk_doc" != yes; then
++ enable_gtk_doc=no
++ fi
++ fi
++
++ AM_CONDITIONAL(ENABLE_GTK_DOC, test x$enable_gtk_doc = xyes)
++ AM_CONDITIONAL(GTK_DOC_USE_LIBTOOL, test -n "$LIBTOOL")
++])
diff --git a/recipes/pango/files/no-tests.patch b/recipes/pango/files/no-tests.patch
new file mode 100644
index 0000000000..b382126129
--- /dev/null
+++ b/recipes/pango/files/no-tests.patch
@@ -0,0 +1,15 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- pango-1.2.5/Makefile.am~no-tests 2003-01-30 22:43:47.000000000 +0100
++++ pango-1.2.5/Makefile.am 2004-03-11 11:31:25.000000000 +0100
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to create Makefile.in.
+
+-SUBDIRS= pango modules examples docs tools tests
++SUBDIRS= pango modules examples docs tools
+
+ EXTRA_DIST = \
+ pango.pc.in \
diff --git a/recipes/pango/files/pkgconfig_fixes.patch b/recipes/pango/files/pkgconfig_fixes.patch
new file mode 100644
index 0000000000..f021591a91
--- /dev/null
+++ b/recipes/pango/files/pkgconfig_fixes.patch
@@ -0,0 +1,79 @@
+Index: pango-1.18.1/configure.in
+===================================================================
+--- pango-1.18.1.orig/configure.in 2007-08-28 00:29:54.000000000 +0000
++++ pango-1.18.1/configure.in 2007-11-12 19:21:22.000000000 +0000
+@@ -226,13 +226,9 @@
+ #
+ # Checks for FreeType
+ #
+- FREETYPE_LIBS=
+- FREETYPE_CFLAGS=
+- AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, no)
+- if test "x$FREETYPE_CONFIG" != "xno" ; then
+- FREETYPE_CFLAGS=`$FREETYPE_CONFIG --cflags`
+- FREETYPE_LIBS=`$FREETYPE_CONFIG --libs`
++ PKG_CHECK_MODULES(FREETYPE, freetype2 >= 1.0.1, have_freetype=true, AC_MSG_RESULT([no]))
+
++ if $have_freetype ; then
+ pango_save_ldflags=$LDFLAGS
+ LDFLAGS="$LDFLAGS $FREETYPE_LIBS"
+ AC_CHECK_LIB(freetype, FT_Get_Next_Char, have_freetype=true, :)
+Index: pango-1.18.1/pangoft2-uninstalled.pc.in
+===================================================================
+--- pango-1.18.1.orig/pangoft2-uninstalled.pc.in 2007-07-05 21:30:28.000000000 +0000
++++ pango-1.18.1/pangoft2-uninstalled.pc.in 2007-11-12 19:23:44.000000000 +0000
+@@ -1,7 +1,7 @@
+ Name: Pango FT2 Uninstalled
+ Description: Freetype 2.0 font support for Pango, Not Installed
+ Version: @VERSION@
+-Requires: pango
+-Libs: ${pc_top_builddir}/${pcfiledir}/pango/libpangoft2-@PANGO_API_VERSION@.la @FREETYPE_LIBS@
+-Cflags: -I${pc_top_builddir}/${pcfiledir}/@srcdir@ @FREETYPE_CFLAGS@
++Requires: pango freetype2
++Libs: ${pc_top_builddir}/${pcfiledir}/pango/libpangoft2-@PANGO_API_VERSION@.la
++Cflags: -I${pc_top_builddir}/${pcfiledir}/@srcdir@
+
+Index: pango-1.18.1/pangoft2.pc.in
+===================================================================
+--- pango-1.18.1.orig/pangoft2.pc.in 2007-07-05 21:30:28.000000000 +0000
++++ pango-1.18.1/pangoft2.pc.in 2007-11-12 19:27:05.000000000 +0000
+@@ -6,7 +6,7 @@
+ Name: Pango FT2
+ Description: Freetype 2.0 font support for Pango
+ Version: @VERSION@
+-Requires: pango
+-Libs: -L${libdir} -lpangoft2-@PANGO_API_VERSION@ @PKGCONFIG_FREETYPE_LIBS@
+-Cflags: -I${includedir}/pango-1.0 @FONTCONFIG_CFLAGS@ @FREETYPE_CFLAGS@
++Requires: pango freetype2 fontconfig
++Libs: -L${libdir} -lpangoft2-@PANGO_API_VERSION@
++Cflags: -I${includedir}/pango-1.0
+
+Index: pango-1.18.1/pangoxft-uninstalled.pc.in
+===================================================================
+--- pango-1.18.1.orig/pangoxft-uninstalled.pc.in 2007-07-05 21:30:28.000000000 +0000
++++ pango-1.18.1/pangoxft-uninstalled.pc.in 2007-11-12 19:22:24.000000000 +0000
+@@ -1,7 +1,7 @@
+ Name: Pango Xft Uninstalled
+ Description: Xft font support for Pango, Not Installed
+ Version: @VERSION@
+-Requires: pango
+-Libs: ${pc_top_builddir}/${pcfiledir}/pango/libpangoxft-@PANGO_API_VERSION@.la @XFT_LIBS@
+-Cflags: -I${pc_top_builddir}/${pcfiledir}/@srcdir@ @X_CFLAGS@ @FREETYPE_CFLAGS@
++Requires: pango xft
++Libs: ${pc_top_builddir}/${pcfiledir}/pango/libpangoxft-@PANGO_API_VERSION@.la
++Cflags: -I${pc_top_builddir}/${pcfiledir}/@srcdir@ @X_CFLAGS@
+
+Index: pango-1.18.1/pangoxft.pc.in
+===================================================================
+--- pango-1.18.1.orig/pangoxft.pc.in 2007-07-05 21:30:28.000000000 +0000
++++ pango-1.18.1/pangoxft.pc.in 2007-11-12 19:21:57.000000000 +0000
+@@ -6,6 +6,6 @@
+ Name: Pango Xft
+ Description: Xft font support for Pango
+ Version: @VERSION@
+-Requires: pango pangoft2
+-Libs: -L${libdir} -lpangoxft-@PANGO_API_VERSION@ @PKGCONFIG_XFT_LIBS@
+-Cflags: -I${includedir}/pango-1.0 @XFT_CFLAGS@
++Requires: pango pangoft2 xft
++Libs: -L${libdir} -lpangoxft-@PANGO_API_VERSION@
++Cflags: -I${includedir}/pango-1.0