aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/patcher
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/patcher
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/patcher')
-rw-r--r--recipes/patcher/files/freebsd_gpatch.patch28
-rw-r--r--recipes/patcher/patcher-native_20040913.bb20
-rw-r--r--recipes/patcher/patcher_20040913.bb15
3 files changed, 63 insertions, 0 deletions
diff --git a/recipes/patcher/files/freebsd_gpatch.patch b/recipes/patcher/files/freebsd_gpatch.patch
new file mode 100644
index 0000000000..ee6365f49d
--- /dev/null
+++ b/recipes/patcher/files/freebsd_gpatch.patch
@@ -0,0 +1,28 @@
+On FreeBSD the default patch program has a different command line
+interface than GNU patch. Make patcher use the GNU patch.
+
+
+--- patcher/patcher.py.old Mon Sep 13 21:59:05 2004
++++ patcher/patcher.py Sun Jul 17 14:24:50 2005
+@@ -631,8 +631,8 @@
+ my $res;
+
+ # ... then we look if the patch would apply cleanly ...
+- print "DEBUG: patch --dry-run $opt\n" if $debug > 1;
+- $res = system("patch --dry-run $opt >$patchlog 2>/dev/null");
++ print "DEBUG: gpatch --dry-run $opt\n" if $debug > 1;
++ $res = system("gpatch --dry-run $opt >$patchlog 2>/dev/null");
+ if ($res != 0) {
+ unless ($do_force) {
+ unlink($patchlog);
+@@ -669,8 +669,8 @@
+ # Finally we apply the patch. No need to create backup copies with -b,
+ # that has been done by PutIntoPatch()
+ $opt = "-f $opt" if $do_force;
+- print "DEBUG: patch $opt\n" if $debug > 1;
+- $res = system("patch $opt >$patchlog");
++ print "DEBUG: gpatch $opt\n" if $debug > 1;
++ $res = system("gpatch $opt >$patchlog");
+ unlink($patchlog);
+ $res = 0 if $do_force && $res == 256;
+ if ($res != 0) {
diff --git a/recipes/patcher/patcher-native_20040913.bb b/recipes/patcher/patcher-native_20040913.bb
new file mode 100644
index 0000000000..c071d52404
--- /dev/null
+++ b/recipes/patcher/patcher-native_20040913.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Patcher is a perl script for managing patches."
+HOMEPAGE = "http://www.holgerschurig.de/patcher.html"
+LICENSE = "Perl"
+DEPENDS = ""
+SECTION = "base"
+PRIORITY = "optional"
+PACKAGES = ""
+PR = "r1"
+
+inherit native
+
+SRC_URI = "http://www.holgerschurig.de/files/linux/patcher-${PV}.tar.bz2"
+SRC_URI_append_build-freebsd = " file://freebsd_gpatch.patch;patch=1 "
+S = "${WORKDIR}/patcher"
+
+PATCHTOOL = "patch"
+
+do_stage() {
+ install -m 0755 patcher.py ${STAGING_BINDIR}/patcher
+}
diff --git a/recipes/patcher/patcher_20040913.bb b/recipes/patcher/patcher_20040913.bb
new file mode 100644
index 0000000000..471f75af7b
--- /dev/null
+++ b/recipes/patcher/patcher_20040913.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Patcher is a perl script for managing patches."
+HOMEPAGE = "http://www.holgerschurig.de/patcher.html"
+LICENSE = "Perl"
+DEPENDS = ""
+SECTION = "base"
+PRIORITY = "optional"
+INHIBIT_DEFAULT_DEPS = "1"
+
+SRC_URI = "http://www.holgerschurig.de/files/linux/patcher-${PV}.tar.bz2"
+S="${WORKDIR}/patcher"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 patcher.py ${D}${bindir}/patcher
+}