aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pax-utils
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-05-06 14:00:35 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-05-06 14:00:35 +0100
commit58ddfb17c765dac487fa720b982bf13b441e743e (patch)
tree10c1561c699a5873e0b5136e9f8511efd48680fe /recipes/pax-utils
parent9da5a071dc6f81c3a3dc59635c599334a515e595 (diff)
downloadopenembedded-58ddfb17c765dac487fa720b982bf13b441e743e.tar.gz
pax-utils-native: Make sure prefix variable is correct during do_install
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'recipes/pax-utils')
-rw-r--r--recipes/pax-utils/pax-utils_0.1.13.bb2
-rw-r--r--recipes/pax-utils/pax-utils_0.1.19.bb4
2 files changed, 4 insertions, 2 deletions
diff --git a/recipes/pax-utils/pax-utils_0.1.13.bb b/recipes/pax-utils/pax-utils_0.1.13.bb
index 5ede5e6cf3..4ca926c2bc 100644
--- a/recipes/pax-utils/pax-utils_0.1.13.bb
+++ b/recipes/pax-utils/pax-utils_0.1.13.bb
@@ -12,7 +12,7 @@ do_compile() {
}
do_install() {
- oe_runmake DESTDIR=${D} install
+ oe_runmake PREFIX=${D}${prefix} DESTDIR=${D} install
}
NATIVE_INSTALL_WORKS = "1"
diff --git a/recipes/pax-utils/pax-utils_0.1.19.bb b/recipes/pax-utils/pax-utils_0.1.19.bb
index 9813126d07..d7cd49fd3b 100644
--- a/recipes/pax-utils/pax-utils_0.1.19.bb
+++ b/recipes/pax-utils/pax-utils_0.1.19.bb
@@ -5,6 +5,8 @@ LICENSE = "GPLv2"
SRC_URI = "http://gentoo.osuosl.org/distfiles/pax-utils-${PV}.tar.bz2"
S = "${WORKDIR}/pax-utils-${PV}"
+PR = "r2"
+
CPPFLAGS += "-D_GNU_SOURCE "
do_compile() {
@@ -12,7 +14,7 @@ do_compile() {
}
do_install() {
- oe_runmake DESTDIR=${D} install
+ oe_runmake PREFIX=${D}${prefix} DESTDIR=${D} install
}
NATIVE_INSTALL_WORKS = "1"