aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pax-utils
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/pax-utils
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/pax-utils')
-rw-r--r--recipes/pax-utils/pax-utils-native_0.1.13.bb12
-rw-r--r--recipes/pax-utils/pax-utils-native_0.1.19.bb12
-rw-r--r--recipes/pax-utils/pax-utils_0.1.13.bb17
-rw-r--r--recipes/pax-utils/pax-utils_0.1.19.bb17
4 files changed, 58 insertions, 0 deletions
diff --git a/recipes/pax-utils/pax-utils-native_0.1.13.bb b/recipes/pax-utils/pax-utils-native_0.1.13.bb
new file mode 100644
index 0000000000..5a56c01aa4
--- /dev/null
+++ b/recipes/pax-utils/pax-utils-native_0.1.13.bb
@@ -0,0 +1,12 @@
+inherit native
+
+require pax-utils_${PV}.bb
+
+do_stage() {
+ oe_runmake PREFIX=${STAGING_DIR_HOST}${layout_prefix} install
+}
+
+do_install() {
+ :
+}
+
diff --git a/recipes/pax-utils/pax-utils-native_0.1.19.bb b/recipes/pax-utils/pax-utils-native_0.1.19.bb
new file mode 100644
index 0000000000..5a56c01aa4
--- /dev/null
+++ b/recipes/pax-utils/pax-utils-native_0.1.19.bb
@@ -0,0 +1,12 @@
+inherit native
+
+require pax-utils_${PV}.bb
+
+do_stage() {
+ oe_runmake PREFIX=${STAGING_DIR_HOST}${layout_prefix} install
+}
+
+do_install() {
+ :
+}
+
diff --git a/recipes/pax-utils/pax-utils_0.1.13.bb b/recipes/pax-utils/pax-utils_0.1.13.bb
new file mode 100644
index 0000000000..c704d288b8
--- /dev/null
+++ b/recipes/pax-utils/pax-utils_0.1.13.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Various ELF utilities"
+HOMEPAGE = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml"
+LICENSE = "GPLv2"
+PR = "r1"
+SRC_URI = "http://gentoo.osuosl.org/distfiles/pax-utils-${PV}.tar.bz2"
+S = "${WORKDIR}/pax-utils-${PV}"
+
+CPPFLAGS += "-D_GNU_SOURCE "
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
diff --git a/recipes/pax-utils/pax-utils_0.1.19.bb b/recipes/pax-utils/pax-utils_0.1.19.bb
new file mode 100644
index 0000000000..bd657d7997
--- /dev/null
+++ b/recipes/pax-utils/pax-utils_0.1.19.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Various ELF utilities"
+HOMEPAGE = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml"
+LICENSE = "GPLv2"
+
+SRC_URI = "http://gentoo.osuosl.org/distfiles/pax-utils-${PV}.tar.bz2"
+S = "${WORKDIR}/pax-utils-${PV}"
+
+CPPFLAGS += "-D_GNU_SOURCE "
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+