aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pcmanfm
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/pcmanfm
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/pcmanfm')
-rw-r--r--recipes/pcmanfm/files/auto_mount.patch10
-rw-r--r--recipes/pcmanfm/files/desired_mount_point.patch91
-rw-r--r--recipes/pcmanfm/files/desktop.patch9
-rw-r--r--recipes/pcmanfm/files/emblem-symbolic-link.pngbin0 -> 999 bytes
-rw-r--r--recipes/pcmanfm/files/gnome-fs-directory.pngbin0 -> 2044 bytes
-rw-r--r--recipes/pcmanfm/files/gnome-fs-regular.pngbin0 -> 3220 bytes
-rw-r--r--recipes/pcmanfm/files/gnome-mime-text-plain.pngbin0 -> 2855 bytes
-rw-r--r--recipes/pcmanfm/pcmanfm_0.5.bb26
8 files changed, 136 insertions, 0 deletions
diff --git a/recipes/pcmanfm/files/auto_mount.patch b/recipes/pcmanfm/files/auto_mount.patch
new file mode 100644
index 0000000000..b4a3125e3d
--- /dev/null
+++ b/recipes/pcmanfm/files/auto_mount.patch
@@ -0,0 +1,10 @@
+--- a/src/vfs/vfs-volume-hal.c 2008-12-16 17:39:21.000000000 -0200
++++ b/src/vfs/vfs-volume-hal.c 2008-12-16 17:37:07.000000000 -0200
+@@ -1237,6 +1237,7 @@
+ {
+ /* add the volume to the volume manager */
+ vfs_volume_add (volume);
++ vfs_volume_mount (volume, NULL);
+ }
+ /* release the HAL drive */
+ libhal_drive_free (hd);
diff --git a/recipes/pcmanfm/files/desired_mount_point.patch b/recipes/pcmanfm/files/desired_mount_point.patch
new file mode 100644
index 0000000000..d548abe8fa
--- /dev/null
+++ b/recipes/pcmanfm/files/desired_mount_point.patch
@@ -0,0 +1,91 @@
+--- a/src/vfs/vfs-volume-hal.c 2008-06-11 15:38:25.000000000 -0300
++++ b/src/vfs/vfs-volume-hal.c 2008-12-16 10:20:18.000000000 -0200
+@@ -944,7 +944,7 @@
+ if (G_LIKELY (desired_mount_point != NULL && *desired_mount_point != '\0'))
+ {
+ filename = g_build_filename (mount_root, desired_mount_point, NULL);
+- volume->mount_point = filename;
++ volume->mount_point = g_strdup( desired_mount_point );
+ }
+ libhal_free_string (desired_mount_point);
+ }
+@@ -954,8 +954,7 @@
+ {
+ /* <mount-root>/<device> looks like a good idea */
+ basename = g_path_get_basename (volume->device_file);
+- filename = g_build_filename (mount_root, basename, NULL);
+- volume->mount_point = filename;
++ volume->mount_point = g_strdup( basename );
+ g_free (basename);
+ }
+
+@@ -2310,7 +2309,7 @@
+ }
+
+ gboolean
+-vfs_volume_hal_mount (ExoMountHalDevice *device,
++vfs_volume_hal_mount (VFSVolume *vol,
+ GError **error)
+ {
+ DBusMessage *message;
+@@ -2323,8 +2322,13 @@
+ const gchar *uuid = NULL, *label = NULL;
+ gint m, n = 0;
+ VFSVolumeOptions opts;
++ ExoMountHalDevice* device = NULL;
++
++ g_return_val_if_fail (vol != NULL, FALSE);
++
++ if (!(device = vfs_volume_hal_from_udi( vol->udi, error )))
++ return FALSE;
+
+- g_return_val_if_fail (device != NULL, FALSE);
+ g_return_val_if_fail (error == NULL || *error == NULL, FALSE);
+
+ if( device->volume != NULL) {
+@@ -2472,16 +2476,23 @@
+ }
+ }
+
+- /* try to determine a usable mount point */
+- if (G_LIKELY (device->volume != NULL))
++ if (G_LIKELY (vol->mount_point == NULL))
+ {
+- /* maybe we can use the volume's label... */
+- mount_point = g_strdup( libhal_volume_get_label (device->volume) );
++ /* try to determine a usable mount point */
++ if (G_LIKELY (device->volume != NULL))
++ {
++ /* maybe we can use the volume's label... */
++ mount_point = g_strdup( libhal_volume_get_label (device->volume) );
++ }
++ else
++ {
++ /* maybe we can use the the textual type... */
++ mount_point = g_strdup( libhal_drive_get_type_textual (device->drive) );
++ }
+ }
+ else
+ {
+- /* maybe we can use the the textual type... */
+- mount_point = g_strdup( libhal_drive_get_type_textual (device->drive) );
++ mount_point = g_strdup( vol->mount_point );
+ }
+
+ /* However, the label may contain G_DIR_SEPARATOR so just replace these
+@@ -2825,13 +2836,10 @@
+
+ gboolean vfs_volume_mount( VFSVolume* vol, GError** err )
+ {
+- ExoMountHalDevice* device;
+ gboolean ret = FALSE;
+- device = vfs_volume_hal_from_udi( vol->udi, err );
+- if( device )
++ if( vol )
+ {
+- ret = vfs_volume_hal_mount( device, err );
+- vfs_volume_hal_free( device );
++ ret = vfs_volume_hal_mount( vol, err );
+ }
+ return ret;
+ }
diff --git a/recipes/pcmanfm/files/desktop.patch b/recipes/pcmanfm/files/desktop.patch
new file mode 100644
index 0000000000..2d8b5a58a2
--- /dev/null
+++ b/recipes/pcmanfm/files/desktop.patch
@@ -0,0 +1,9 @@
+--- pcmanfm-0.3.2-beta/pcmanfm.desktop.in.old 2006-09-25 11:43:07.000000000 +0100
++++ pcmanfm-0.3.2-beta/pcmanfm.desktop.in 2006-09-25 11:44:59.000000000 +0100
+@@ -1,4 +1,4 @@
+ [Desktop Entry]
+ Encoding=UTF-8
+-Name=PCMan File Manager
++Name=File Manager
+ Categories=Application;System;Utility;Core;GTK;
+
diff --git a/recipes/pcmanfm/files/emblem-symbolic-link.png b/recipes/pcmanfm/files/emblem-symbolic-link.png
new file mode 100644
index 0000000000..b8e559456e
--- /dev/null
+++ b/recipes/pcmanfm/files/emblem-symbolic-link.png
Binary files differ
diff --git a/recipes/pcmanfm/files/gnome-fs-directory.png b/recipes/pcmanfm/files/gnome-fs-directory.png
new file mode 100644
index 0000000000..05921a6689
--- /dev/null
+++ b/recipes/pcmanfm/files/gnome-fs-directory.png
Binary files differ
diff --git a/recipes/pcmanfm/files/gnome-fs-regular.png b/recipes/pcmanfm/files/gnome-fs-regular.png
new file mode 100644
index 0000000000..ce77a8e62d
--- /dev/null
+++ b/recipes/pcmanfm/files/gnome-fs-regular.png
Binary files differ
diff --git a/recipes/pcmanfm/files/gnome-mime-text-plain.png b/recipes/pcmanfm/files/gnome-mime-text-plain.png
new file mode 100644
index 0000000000..bfe4bad56c
--- /dev/null
+++ b/recipes/pcmanfm/files/gnome-mime-text-plain.png
Binary files differ
diff --git a/recipes/pcmanfm/pcmanfm_0.5.bb b/recipes/pcmanfm/pcmanfm_0.5.bb
new file mode 100644
index 0000000000..489e95ee72
--- /dev/null
+++ b/recipes/pcmanfm/pcmanfm_0.5.bb
@@ -0,0 +1,26 @@
+LICENSE = "GPL"
+DESCRIPTION = "procfs tools"
+SECTION = "x11"
+PRIORITY = "optional"
+DEPENDS = "gtk+ hal gamin startup-notification"
+RRECOMMENDS = "pmount-hal"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/pcmanfm-${PV}.tar.gz \
+ file://desired_mount_point.patch;patch=1 \
+ file://auto_mount.patch;patch=1 \
+ file://gnome-fs-directory.png \
+ file://gnome-fs-regular.png \
+ file://gnome-mime-text-plain.png \
+ file://emblem-symbolic-link.png \
+ file://desktop.patch;patch=1"
+
+inherit autotools pkgconfig
+
+do_install_append () {
+ install -d ${D}/${datadir}
+ install -d ${D}/${datadir}/pixmaps/
+
+ install -m 0644 ${WORKDIR}/*.png ${D}/${datadir}/pixmaps
+}
+
+FILES_${PN} += "${datadir}/pixmaps/*.png"