aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pcmanfm
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2009-09-04 18:23:02 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2009-09-17 14:20:37 -0300
commit7daf6b3e17b866ab2ca38b2c64d7722b4498a09a (patch)
treec07b435efadac6bc4318bb76fca1afe88b54e46b /recipes/pcmanfm
parent4fdfbf9af2f4f1576b1ece20f43167f2c2d9f1c2 (diff)
downloadopenembedded-7daf6b3e17b866ab2ca38b2c64d7722b4498a09a.tar.gz
pcmanfm: fix automounting support
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes/pcmanfm')
-rw-r--r--recipes/pcmanfm/files/auto_mount.patch28
-rw-r--r--recipes/pcmanfm/pcmanfm_0.5.bb1
2 files changed, 19 insertions, 10 deletions
diff --git a/recipes/pcmanfm/files/auto_mount.patch b/recipes/pcmanfm/files/auto_mount.patch
index b4a3125e3d..288dff4d47 100644
--- a/recipes/pcmanfm/files/auto_mount.patch
+++ b/recipes/pcmanfm/files/auto_mount.patch
@@ -1,10 +1,18 @@
---- a/src/vfs/vfs-volume-hal.c 2008-12-16 17:39:21.000000000 -0200
-+++ b/src/vfs/vfs-volume-hal.c 2008-12-16 17:37:07.000000000 -0200
-@@ -1237,6 +1237,7 @@
- {
- /* add the volume to the volume manager */
- vfs_volume_add (volume);
-+ vfs_volume_mount (volume, NULL);
- }
- /* release the HAL drive */
- libhal_drive_free (hd);
+commit 773ce494a6299e2fdc266e30bcb57305f13cc9d1
+Author: Luis Gustavo S. Barreto <gustavo@ossystems.com.br>
+Date: Mon Sep 7 09:27:35 2009 -0300
+
+ auto
+
+diff --git a/src/vfs/vfs-volume-hal.c b/src/vfs/vfs-volume-hal.c
+index 761ac33..ec5c64f 100644
+--- a/src/vfs/vfs-volume-hal.c
++++ b/src/vfs/vfs-volume-hal.c
+@@ -1177,6 +1177,7 @@ vfs_volume_update_volume_by_udi ( const gchar *udi)
+ static void vfs_volume_add( VFSVolume* volume )
+ {
+ volumes = g_list_append( volumes, volume );
++ vfs_volume_mount( volume, NULL );
+ call_callbacks( volume, VFS_VOLUME_ADDED );
+ }
+
diff --git a/recipes/pcmanfm/pcmanfm_0.5.bb b/recipes/pcmanfm/pcmanfm_0.5.bb
index 489e95ee72..483acba4b2 100644
--- a/recipes/pcmanfm/pcmanfm_0.5.bb
+++ b/recipes/pcmanfm/pcmanfm_0.5.bb
@@ -4,6 +4,7 @@ SECTION = "x11"
PRIORITY = "optional"
DEPENDS = "gtk+ hal gamin startup-notification"
RRECOMMENDS = "pmount-hal"
+PR = "r3"
SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/pcmanfm-${PV}.tar.gz \
file://desired_mount_point.patch;patch=1 \