aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pcmciautils/pcmciautils-013
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/pcmciautils/pcmciautils-013
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/pcmciautils/pcmciautils-013')
-rw-r--r--recipes/pcmciautils/pcmciautils-013/makefile_fix.patch20
-rw-r--r--recipes/pcmciautils/pcmciautils-013/version_workaround.patch16
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes/pcmciautils/pcmciautils-013/makefile_fix.patch b/recipes/pcmciautils/pcmciautils-013/makefile_fix.patch
new file mode 100644
index 0000000000..a45f9e20e3
--- /dev/null
+++ b/recipes/pcmciautils/pcmciautils-013/makefile_fix.patch
@@ -0,0 +1,20 @@
+Hardcoded paths are bad...
+
+Index: pcmciautils-013/Makefile
+===================================================================
+--- pcmciautils-013.orig/Makefile 2006-03-26 11:56:41.000000000 +0100
++++ pcmciautils-013/Makefile 2006-05-09 22:10:16.000000000 +0100
+@@ -69,11 +69,11 @@
+ mandir = ${prefix}/usr/share/man
+ srcdir = .
+
+-INSTALL = /usr/bin/install -c
++INSTALL = install -c
+ INSTALL_PROGRAM = ${INSTALL}
+ INSTALL_DATA = ${INSTALL} -m 644
+ INSTALL_SCRIPT = ${INSTALL_PROGRAM}
+-SYMLINK = /usr/bin/ln -sf
++SYMLINK = ln -sf
+
+ # place to put our hotplug scripts nodes
+ hotplugdir = ${etcdir}/hotplug
diff --git a/recipes/pcmciautils/pcmciautils-013/version_workaround.patch b/recipes/pcmciautils/pcmciautils-013/version_workaround.patch
new file mode 100644
index 0000000000..ff34e139b3
--- /dev/null
+++ b/recipes/pcmciautils/pcmciautils-013/version_workaround.patch
@@ -0,0 +1,16 @@
+PCMCIAUTILS_VERSION is specified on the commandline but doesn't compile properly
+under arm gcc 3.4.x so we work around it.
+
+Index: pcmciautils-013/src/pccardctl.c
+===================================================================
+--- pcmciautils-013.orig/src/pccardctl.c 2006-03-26 11:56:41.000000000 +0100
++++ pcmciautils-013/src/pccardctl.c 2006-05-09 22:11:09.000000000 +0100
+@@ -350,7 +350,7 @@
+ }
+
+ static void print_header(void) {
+- printf("pcmciautils %s\n", PCMCIAUTILS_VERSION);
++ printf("pcmciautils 013\n");
+ printf("Copyright (C) 2004-2005 Dominik Brodowski, (C) 1999 David A. Hinds\n");
+ printf("Report errors and bugs to <linux-pcmcia@lists.infradead.org>, please.\n");
+ }