aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pcmciautils/pcmciautils-015/ccdv.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/pcmciautils/pcmciautils-015/ccdv.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/pcmciautils/pcmciautils-015/ccdv.patch')
-rw-r--r--recipes/pcmciautils/pcmciautils-015/ccdv.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/pcmciautils/pcmciautils-015/ccdv.patch b/recipes/pcmciautils/pcmciautils-015/ccdv.patch
new file mode 100644
index 0000000000..460e3938aa
--- /dev/null
+++ b/recipes/pcmciautils/pcmciautils-015/ccdv.patch
@@ -0,0 +1,34 @@
+From: Olivier Blin <blino@mandriva.com>
+Date: Wed, 13 Aug 2008 20:30:14 +0000 (+0200)
+Subject: fix parallel build of ccdv
+X-Git-Url: http://git.kernel.org/?p=linux%2Fpcmcia%2Fpcmciautils.git;a=commitdiff_plain;h=ff72508f29567028597d8816bdf8b55c3c61a314
+
+fix parallel build of ccdv
+
+Parallel build was broken because ccdv was not necessarily built
+before the object files were built (occured with make -j4).
+
+Signed-off-by: Olivier Blin <blino@mandriva.com>
+Signed-off-by: Dominik Brodowski <linux@dominikbrodowski.net>
+---
+
+diff --git a/Makefile b/Makefile
+index cc30ae4..e1d7c85 100644
+--- a/Makefile
++++ b/Makefile
+@@ -208,11 +208,12 @@ UDEV_RULES += udev/rules-end
+
+ all: ccdv $(PCCARDCTL) $(PCMCIA_CHECK_BROKEN_CIS) $(PCMCIA_SOCKET_STARTUP_BUILD) udevrules
+
+-ccdv:
++ccdv: build/ccdv
++build/ccdv: build/ccdv.c
+ @echo "Building ccdv"
+- @$(HOSTCC) -O1 build/ccdv.c -o build/ccdv
++ @$(HOSTCC) -O1 $< -o $@
+
+-.c.o:
++%.o : %.c ccdv
+ $(QUIET) $(CC) $(CFLAGS) -c -o $@ $<
+
+ %.c %.h : %.y