aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pcmciautils/pcmciautils-015
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/pcmciautils/pcmciautils-015
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/pcmciautils/pcmciautils-015')
-rw-r--r--recipes/pcmciautils/pcmciautils-015/ccdv.patch34
-rw-r--r--recipes/pcmciautils/pcmciautils-015/makefile_fix.patch88
-rw-r--r--recipes/pcmciautils/pcmciautils-015/version_workaround.patch16
3 files changed, 138 insertions, 0 deletions
diff --git a/recipes/pcmciautils/pcmciautils-015/ccdv.patch b/recipes/pcmciautils/pcmciautils-015/ccdv.patch
new file mode 100644
index 0000000000..460e3938aa
--- /dev/null
+++ b/recipes/pcmciautils/pcmciautils-015/ccdv.patch
@@ -0,0 +1,34 @@
+From: Olivier Blin <blino@mandriva.com>
+Date: Wed, 13 Aug 2008 20:30:14 +0000 (+0200)
+Subject: fix parallel build of ccdv
+X-Git-Url: http://git.kernel.org/?p=linux%2Fpcmcia%2Fpcmciautils.git;a=commitdiff_plain;h=ff72508f29567028597d8816bdf8b55c3c61a314
+
+fix parallel build of ccdv
+
+Parallel build was broken because ccdv was not necessarily built
+before the object files were built (occured with make -j4).
+
+Signed-off-by: Olivier Blin <blino@mandriva.com>
+Signed-off-by: Dominik Brodowski <linux@dominikbrodowski.net>
+---
+
+diff --git a/Makefile b/Makefile
+index cc30ae4..e1d7c85 100644
+--- a/Makefile
++++ b/Makefile
+@@ -208,11 +208,12 @@ UDEV_RULES += udev/rules-end
+
+ all: ccdv $(PCCARDCTL) $(PCMCIA_CHECK_BROKEN_CIS) $(PCMCIA_SOCKET_STARTUP_BUILD) udevrules
+
+-ccdv:
++ccdv: build/ccdv
++build/ccdv: build/ccdv.c
+ @echo "Building ccdv"
+- @$(HOSTCC) -O1 build/ccdv.c -o build/ccdv
++ @$(HOSTCC) -O1 $< -o $@
+
+-.c.o:
++%.o : %.c ccdv
+ $(QUIET) $(CC) $(CFLAGS) -c -o $@ $<
+
+ %.c %.h : %.y
diff --git a/recipes/pcmciautils/pcmciautils-015/makefile_fix.patch b/recipes/pcmciautils/pcmciautils-015/makefile_fix.patch
new file mode 100644
index 0000000000..f5bb64b9bd
--- /dev/null
+++ b/recipes/pcmciautils/pcmciautils-015/makefile_fix.patch
@@ -0,0 +1,88 @@
+Hardcoded paths are bad...
+
+Index: pcmciautils-014/Makefile
+===================================================================
+--- pcmciautils-014.orig/Makefile 2006-06-01 11:07:52.000000000 +0200
++++ pcmciautils-014/Makefile 2006-10-29 13:50:25.000000000 +0100
+@@ -69,7 +69,7 @@
+ mandir = ${prefix}/usr/share/man
+ srcdir = .
+
+-INSTALL = /usr/bin/install -c
++INSTALL = install -c
+ INSTALL_PROGRAM = ${INSTALL}
+ INSTALL_DATA = ${INSTALL} -m 644
+ INSTALL_SCRIPT = ${INSTALL_PROGRAM}
+--- pcmciautils-014/Makefile~ 2007-05-25 19:40:39.000000000 +0200
++++ pcmciautils-014/Makefile 2007-05-25 19:40:39.000000000 +0200
+@@ -258,28 +258,29 @@
+
+ install-hotplug:
+ $(INSTALL) -d $(DESTDIR)$(hotplugdir)
+- $(INSTALL_PROGRAM) -D hotplug/pcmcia.agent $(DESTDIR)$(hotplugdir)/pcmcia.agent
+- $(INSTALL_PROGRAM) -D hotplug/pcmcia.rc $(DESTDIR)$(hotplugdir)/pcmcia.rc
++ $(INSTALL_PROGRAM) hotplug/pcmcia.agent $(DESTDIR)$(hotplugdir)/pcmcia.agent
++ $(INSTALL_PROGRAM) hotplug/pcmcia.rc $(DESTDIR)$(hotplugdir)/pcmcia.rc
+
+ uninstall-hotplug:
+ - rm -f $(DESTDIR)$(hotplugdir)/pcmcia.agent $(DESTDIR)$(hotplugdir)/pcmcia.rc
+
+ install-socket-hotplug:
+- $(INSTALL_PROGRAM) -D hotplug/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent
+- $(INSTALL_PROGRAM) -D hotplug/pcmcia_socket.rc $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
++ $(INSTALL_PROGRAM) hotplug/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent
++ $(INSTALL_PROGRAM) hotplug/pcmcia_socket.rc $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
+
+ uninstall-socket-hotplug:
+ - rm -f $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
+ install-socket-tools:
+- $(INSTALL_PROGRAM) -D $(PCMCIA_SOCKET_STARTUP) $(DESTDIR)$(sbindir)/$(PCMCIA_SOCKET_STARTUP)
++ $(INSTALL) -d $(DESTDIR)$(sbindir)
++ $(INSTALL_PROGRAM) $(PCMCIA_SOCKET_STARTUP) $(DESTDIR)$(sbindir)/$(PCMCIA_SOCKET_STARTUP)
+
+ uninstall-socket-tools:
+ - rm -f $(DESTDIR)$(sbindir)/$(PCMCIA_SOCKET_STARTUP)
+
+ install-tools:
+ $(INSTALL) -d $(DESTDIR)$(sbindir)
+- $(INSTALL_PROGRAM) -D $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(PCCARDCTL)
+- $(INSTALL_PROGRAM) -D $(PCMCIA_CHECK_BROKEN_CIS) $(DESTDIR)$(sbindir)/$(PCMCIA_CHECK_BROKEN_CIS)
++ $(INSTALL_PROGRAM) $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(PCCARDCTL)
++ $(INSTALL_PROGRAM) $(PCMCIA_CHECK_BROKEN_CIS) $(DESTDIR)$(sbindir)/$(PCMCIA_CHECK_BROKEN_CIS)
+ $(SYMLINK) $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(LSPCMCIA)
+
+ uninstall-tools:
+@@ -289,18 +290,20 @@
+
+ install-config:
+ $(INSTALL) -d $(DESTDIR)$(pcmciaconfdir)
+- $(INSTALL_DATA) -D config/config.opts $(DESTDIR)$(pcmciaconfdir)/config.opts
++ $(INSTALL_DATA) config/config.opts $(DESTDIR)$(pcmciaconfdir)/config.opts
+
+ uninstall-config:
+ # - rm -f $(DESTDIR)$(pcmciaconfdir)/config.opts
+
+ install-udev:
+- $(INSTALL_DATA) -D $(UDEV_RULES_FILE) $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
++ $(INSTALL) -d $(DESTDIR)$(udevrulesdir)
++ $(INSTALL_DATA) $(UDEV_RULES_FILE) $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
+
+ uninstall-udev:
+ - rm -f $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
+
+ install-man:
++ $(INSTALL) -d $(DESTDIR)$(mandir)/man8
+ $(INSTALL_DATA) -D man/man8/pccardctl.8 $(DESTDIR)$(mandir)/man8/pccardctl.8
+ $(SYMLINK) pccardctl.8 $(DESTDIR)$(mandir)/man8/lspcmcia.8
+
+--- pcmciautils-014/Makefile~ 2007-05-25 19:43:01.000000000 +0200
++++ pcmciautils-014/Makefile 2007-05-25 19:43:01.000000000 +0200
+@@ -304,7 +304,7 @@
+
+ install-man:
+ $(INSTALL) -d $(DESTDIR)$(mandir)/man8
+- $(INSTALL_DATA) -D man/man8/pccardctl.8 $(DESTDIR)$(mandir)/man8/pccardctl.8
++ $(INSTALL_DATA) man/man8/pccardctl.8 $(DESTDIR)$(mandir)/man8/pccardctl.8
+ $(SYMLINK) pccardctl.8 $(DESTDIR)$(mandir)/man8/lspcmcia.8
+
+ uninstall-man:
diff --git a/recipes/pcmciautils/pcmciautils-015/version_workaround.patch b/recipes/pcmciautils/pcmciautils-015/version_workaround.patch
new file mode 100644
index 0000000000..962aa4e246
--- /dev/null
+++ b/recipes/pcmciautils/pcmciautils-015/version_workaround.patch
@@ -0,0 +1,16 @@
+PCMCIAUTILS_VERSION is specified on the commandline but doesn't compile properly
+under arm gcc 3.4.x so we work around it.
+
+Index: pcmciautils-013/src/pccardctl.c
+===================================================================
+--- pcmciautils-013.orig/src/pccardctl.c 2006-03-26 11:56:41.000000000 +0100
++++ pcmciautils-013/src/pccardctl.c 2006-05-09 22:11:09.000000000 +0100
+@@ -350,7 +350,7 @@
+ }
+
+ static void print_header(void) {
+- printf("pcmciautils %s\n", PCMCIAUTILS_VERSION);
++ printf("pcmciautils 014\n");
+ printf("Copyright (C) 2004-2005 Dominik Brodowski, (C) 1999 David A. Hinds\n");
+ printf("Report errors and bugs to <linux-pcmcia@lists.infradead.org>, please.\n");
+ }