summaryrefslogtreecommitdiffstats
path: root/recipes/pcsc-lite
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/pcsc-lite
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/pcsc-lite')
-rw-r--r--recipes/pcsc-lite/files/pcscd.init32
-rw-r--r--recipes/pcsc-lite/pcsc-lite_1.4.102.bb35
2 files changed, 67 insertions, 0 deletions
diff --git a/recipes/pcsc-lite/files/pcscd.init b/recipes/pcsc-lite/files/pcscd.init
new file mode 100644
index 0000000000..92385ab196
--- /dev/null
+++ b/recipes/pcsc-lite/files/pcscd.init
@@ -0,0 +1,32 @@
+#!/bin/sh
+DAEMON=/usr/sbin/pcscd
+NAME=pcscd
+DESC="PCSC Daemon"
+PIDFILE=/var/run/pcscd/pcscd.pid
+ARGS=""
+
+test -f $DAEMON || exit 0
+
+case "$1" in
+ start)
+ echo -n "Starting $DESC: $NAME"
+ start-stop-daemon --start --quiet --pidfile $PIDFILE --exec $DAEMON -- $ARGS
+ echo "."
+ ;;
+ stop)
+ echo -n "Stopping $DESC: $NAME"
+ start-stop-daemon --stop --quiet --pidfile $PIDFILE --exec $DAEMON
+ echo "."
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart}"
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes/pcsc-lite/pcsc-lite_1.4.102.bb b/recipes/pcsc-lite/pcsc-lite_1.4.102.bb
new file mode 100644
index 0000000000..0455ae47a8
--- /dev/null
+++ b/recipes/pcsc-lite/pcsc-lite_1.4.102.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "PC/SC Lite smart card framework and applications"
+HOMEPAGE = "http://pcsclite.alioth.debian.org/"
+LICENSE = "BSD"
+PR = "r0"
+
+DEPENDS = "hal"
+RDEPENDS_${PN} = "hal"
+
+SRC_URI = "http://alioth.debian.org/download.php/2479/pcsc-lite-${PV}.tar.bz2 \
+ file://pcscd.init "
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "pcscd"
+INITSCRIPT_PARAMS = "defaults"
+
+EXTRA_OECONF = " \
+ --enable-libhal \
+ --disable-libusb \
+ --enable-usbdropdir=${libdir}/pcsc/drivers \
+ "
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install() {
+ oe_runmake DESTDIR="${D}" install
+ install -d "${D}/etc/init.d"
+ install -m 755 "${WORKDIR}/pcscd.init" "${D}/etc/init.d/pcscd"
+}
+
+PACKAGES =+ "libpcsclite"
+
+FILES_libpcsclite = "${libdir}/libpcsclite.so.*"