aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pdm/pdm_1.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/pdm/pdm_1.0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/pdm/pdm_1.0.bb')
-rw-r--r--recipes/pdm/pdm_1.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/pdm/pdm_1.0.bb b/recipes/pdm/pdm_1.0.bb
new file mode 100644
index 0000000000..d80e836e8a
--- /dev/null
+++ b/recipes/pdm/pdm_1.0.bb
@@ -0,0 +1,21 @@
+SECTION = "x11/base"
+LICENSE = "GPL"
+DESCRIPTION = "pdm is a minimal session manager for GUIs."
+
+SRC_URI="http://www.penguru.net/download/${PN}-${PV}.tar.gz \
+ file://pdm-1.0-changes.patch;patch=1 \
+ file://pdm.conf \
+ file://xfce \
+ file://mythtv"
+
+do_install() {
+ install -d ${D}${sbindir} \
+ ${D}${sysconfdir}/pdm/sessions \
+ ${D}${sysconfdir}/pdm/plugins
+
+ install -m 0755 pdm ${D}${sbindir}/pdm
+ install -m 0644 conf/pdm.conf* ${D}${sysconfdir}/pdm/
+ install -m 0644 ${WORKDIR}/pdm.conf ${D}${sysconfdir}/pdm/
+ install -m 755 ${WORKDIR}/xfce ${D}${sysconfdir}/pdm/sessions/xfce
+ install -m 755 ${WORKDIR}/mythtv ${D}${sysconfdir}/pdm/sessions/mythtv
+}