aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl/libdbd-sqlite-perl_1.29.bb
diff options
context:
space:
mode:
authorMichael Lippautz <michael.lippautz@gmail.com>2010-03-02 13:19:34 +0100
committerMichael Lippautz <michael.lippautz@gmail.com>2010-03-02 13:27:57 +0100
commit09bb1fc0bfd6bd9e2a1c592f239f825dd998503b (patch)
treefed12edc902ea0a106cd42cad1c4b418bf4f0b0c /recipes/perl/libdbd-sqlite-perl_1.29.bb
parentf45f0d3495aba36aafc286d25f96d5bd9a82c7d9 (diff)
downloadopenembedded-09bb1fc0bfd6bd9e2a1c592f239f825dd998503b.tar.gz
libdbd-sqlite-perl: New recipe (Perl SQLite db backend)
Diffstat (limited to 'recipes/perl/libdbd-sqlite-perl_1.29.bb')
-rw-r--r--recipes/perl/libdbd-sqlite-perl_1.29.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/perl/libdbd-sqlite-perl_1.29.bb b/recipes/perl/libdbd-sqlite-perl_1.29.bb
new file mode 100644
index 0000000000..1f0c5d2f92
--- /dev/null
+++ b/recipes/perl/libdbd-sqlite-perl_1.29.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "PERL database interface driver for the SQLite database."
+SECTION = "libs"
+LICENSE = "Artistic GPL"
+DEPENDS_${PN} += "libdbi-perl-native"
+RDEPENDS_${PN} += "libdbi-perl \
+ perl-module-file-spec \
+ perl-module-file-path \
+ perl-module-scalar-util \
+ perl-module-list-util \
+ perl-module-test \
+ perl-module-test-more \
+ perl-module-test-harness \
+ perl-module-file-basename \
+ perl-module-storable \
+ perl-module-extutils-makemaker \
+ perl-module-locale \
+ perl-module-tie-hash \
+"
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/DBD-SQLite-${PV}.tar.gz;name=dbdsqlite"
+SRC_URI[dbdsqlite.md5sum] = "2a47cea6ecff62508775d90151a8030f"
+SRC_URI[dbdsqlite.sha256sum] = "51d0d529e453ada1ce85772deb5cc4c86a2ebe9da2dd2fb0b40b77b555720867"
+
+S = "${WORKDIR}/DBD-SQLite-${PV}"
+
+inherit cpan